Support » Plugin: WordPress Simple PayPal Shopping Cart » New problem using Paypal Smart payments

  • Resolved zamplify1

    (@zamplify1)


    Thanks for a great plugin. I use it on 2 sites and its been perfect so far.
    On Tales from the Himalaya though it has just started causing a problem. I upgraded to 4.5.4 2 days ago, so I think it started happening then. WordPress is up to date (5.6.2) and there have been sales since WordPress was updated. The plugin was set up to use Paypal Smart payments. On purchase the buyer gets taken most of the way through the paypal dialogue but gets stuck at the end with a “Processing” message under a grey and blue spinner with a lock in the middle. Clicking the underlying window reveals the message “Error occurred during PayPal Smart Checkout process. Reference Error: JQuery is not defined”. I disabled all plugins – no help. I also tried installing the “enable jquery migrate helper plugin” but that didn’t help either (and no errors found). I have set it to Standard Paypal payments and it’s working fine (if you try it I changed the paypal yellow button for the blue one, but it is on standard). I have read your posts referring to the recent double payments problem so suspect it may be to do with whatever changes you made in 4.5.4 to solve that problem.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    I use it on 2 sites and its been perfect so far.
    On Tales from the Himalaya though it has just started causing a problem. I upgraded to 4.5.4 2 days ago, so I think it started happening then.

    Do both sites have identical plugins? Are they hosted in the same server? If not, what is the difference between both sites? This can help to determine why it is working in one site and not the other site.

    Thank you

    Thread Starter zamplify1

    (@zamplify1)

    Thanks for the rapid reply. Yes, both use version 4.5.4 of the plugin, both on WordPress 5.6.2, both hosted at Fastcomet (although different contracts and pointed at different nameservers, so presumably different servers). They are using different custom themes, both based on underscores. The main difference though is that the site which wasn’t working was using the Paypal Smart payments option and also has discount coupons enabled. The working site uses Paypal Standard payments and no discount coupons enabled. On the faulty site, once I turned off Paypal Smart payments it started working fine (with discount coupons still enabled), so the problem must lie in the Smart Payments feature I believe. This is not an urgent problem for me, since it is working OK with Standard payments, but I thought you would like to know.

    Thread Starter zamplify1

    (@zamplify1)

    Two additional bits of info I should have mentioned before:
    1. Each failed attempt at purchase was putting an entry in the Cart Orders Bin, blank except for an order ID and status “in progress”.
    2. I enabled debug (ipn_handle_debug.txt) but there was no output to it at all.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Thank you for providing more information. Are you able to carry out a test purchase in the site that is not working with PayPal Smart payments activated. Make sure debug is also enabled.

    Let me know what happens.

    Thank you

    • This reply was modified 6 months, 3 weeks ago by mbrsolution.
    Thread Starter zamplify1

    (@zamplify1)

    Thanks for the reply. Yes, I can do that – it might be a day or two before I can get to it though. I’ll let you know.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘New problem using Paypal Smart payments’ is closed to new replies.