Support » Plugin: WP Songbook » New Problem: “Fatal Error” on actual Web site

  • Resolved jbearden

    (@jbearden)


    This plugin finally got all its problems resolved when I was running it on my local (Wamp) server. I just tried to install it on my actual Web site (sky-pilot.net, hosted by GoDaddy), and when I tried to activate it, got this message: “Parse error: syntax error, unexpected T_FUNCTION in /home/content/j/b/e/jbearden41/html/skypilot/wp-content/plugins/wp-songbook/inc/class.base.php on line 39”. I can’t trace the path referenced in the message with the GoDaddy File Manager, so I’m not even sure where to look for what might have caused this error. Any ideas? I hope you can fix this, because, as I said, it finally got to working really well on my local host, and I’d like to use it on the actual Web site if I could.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author sjiamnocna

    (@sjiamnocna)

    Hi! Thank you for reporting that.
    It’s actually problem with the server, or its configuration. In the plugin I use anonymous functions to simplify adding of filters or actions that appears only once. Unfortunately anonymous functions were added in PHP version 5.3. If your server has installed lower version, you get this error message.

    I’ll try make some workaround for this.

    Thanks very much for the hint! I went into the server configuration, discovered my account was still using PHP v. 5.2, but also that v. 5.3 was available. I upgraded to v. 5.3, and now your plugin seems to work without activation problems. So as far as I’m concerned, no work-around is necessary. Thanks again!

    Plugin Author sjiamnocna

    (@sjiamnocna)

    I’m glad it helped.

    Have a nice time with WP Songbook! 🙂

    BTW; Let me note, that the PHP 7.0 is there out about half a year, so godaddy could make a decision to enable it; The newer version of PHP, more plugins and new features will be available to you as PHP7 brings some great improvements (at least for me)
    https://uk.godaddy.com/community/Developer-Cloud-Portal/Newer-version-of-PHP/m-p/5701

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘New Problem: “Fatal Error” on actual Web site’ is closed to new replies.