Support » Plugin: Search Everything » New posts give an error message

  • Fatal error: Cannot use object of type WP_Error as array in /home1/markmuse2007/public_html/wordpress/wp-content/plugins/search-everything/search-everything.php on line 927

    This is the message whenever I make a new post (click “publish”). Started after installation of Search Everything. If I back out of the message page and reload the site the new post is there.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • +1 … agreed. I’m having the same issue.

    This plugin also causes issues with filtration of posts in the admin list … “/edit.php?s&post_status=all” … if you delete the
    “?s” and just use “post_status=all” it works again but … maybe something within search everything looking for a URL var of “s” … I’d have to dig into the code and I don’t have time so I just deactivated the plugin for now.

    +1 and I also have an issue with media filtering in the library. It currently only works in tile mode, not list view. Not sure it is caused be Search Everything, because the problem persists when the plug-in is deactivated.

    This appears to be related to a call to api.zemanta.com (specifically http://api.zemanta.com/services/rest/0.0/), but that hostname/service no longer exists. The SE plugin does not properly handle the error, and that’s the reason you get:

    Fatal error: Cannot use object of type WP_Error as array in /home1/markmuse2007/public_html/wordpress/wp-content/plugins/search-everything/search-everything.php on line 927

    Unfortunately, I think the plugin authors are the only ones who will be able to actually fix this. Until then, you can edit search-everything.php and change lines 927–930 from:

        $response = json_decode($zemanta_response['body']);
        if (isset($response->status) && !is_wp_error($zemanta_response)) {
          $status = $response->status;
        }

    to:

        if (!is_wp_error($zemanta_response)) {
          $response = json_decode($zemanta_response['body']);
          if (isset($response->status)) {
            $status = $response->status;
          }
        }

    That should at least handle the error properly (though I’m still waiting on confirmation from our affected client). The Zemanta folks will need to chime in on the missing API.

    Thanks agathongroup. Even the temp patch is above my pay grade, but I do have a workaround. The new post does get posted in spite of the error message, so I simply reload the page.

    @agathongroup Thank you, that worked.

    Thanks, @agathongroup – that worked perfectly.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘New posts give an error message’ is closed to new replies.