Support » Plugin: Polylang » New posts are not shown

  • Hi,

    I have a issue with my custom posts.
    Everytime a new custom post is created it is not shown.
    It only shows the post if I go to Settings -> Languages -> Setting
    and check the There are posts, pages, categories.... box.

    Can I set this to deafault? So I don’t have to do this with every post?


Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi, I have no pbs with my custom posts.
    How do you add these ? (in your functions.php ? witch code ?)
    They not shown on the admin or on the front ?


    I see the custom_post in the settings field and I check the checkbox that I want them to show if there is no translation.

    The problem is that everytime a new custom_post post is created it doesn’t show.

    If I go to the settings page I see the checkbox with red text saying that there are posts, pages, categogries ….. that have no translation, would you like to set them to default.

    So I check the box and the custom post is shown. But when I create a new custom_post post the same thing happens.


    Hi, you don’t answer my questions.
    In settings>languages>settings check the custom post types you want to be translatable. After that they will be translatable like the other post types (page, post).
    It is not for “show them if there is no translation”. Just to be taken into account by polylang.
    How do you make your custom post type ? functions.php or plugin ?
    where the custom post is shown or not ? in the admin or on the site ?
    You have to be more specific.


    My custom post type is created by another plugin.
    The custom post is shown on the site.

    I thought I was pretty clear.


    Whitch plugin ? I think your problem come from the plugin who don’t work well with polylang.
    Maybe you don’t need this plugin. It’s not to complicate to make yourself your own custom type.

    when you create a new custom post do you have this kind of meta box ?

    It’s JobManager.
    So it’s not just to create a custom_post.
    If there is a new vacancy created I don’t have an option to translate it!

    So I think the problem come from JobManager/polylang and I don’t think I can really help. I don’t know this plugin and may be it’s complicated.

    Do you have vacancy in the settings>languages>settings>Custom post types ?

    Thnx for looking in to it.
    Yes it is in the settings as a custom_post type.
    I have checked and saved it and it works.

    Plugin Support Chrystl


    Job Manager doesn’t use the standard WordPress filters and actions.
    Its interface is very independent of WordPress and not authorizes to add columns or metaboxes.

    Even in the new updated version?
    The plugin has been down for some years (2 i believe) but they have given it new life.

    If so… What can I do? I use the JobManager for a few years now and I can’t switch to another because that would be way to much work….

    Plugin Support Chrystl


    I tested the 0.7.24 Version. Contact the authors to see if they can add the right WordPress filters and actions.

    Well this s**ks.
    I have no idea how complicated this is but can you tell me which filters and actions I need to tell them?

    Thnx for your effort so far!


    Plugin Support Chrystl






    I’ll come back with a status update!

    Hi mvanboordt,

    do you have any update ?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘New posts are not shown’ is closed to new replies.