Support » Plugin: Plugin Organizer » New Posts are ignoring plugins that are not to be loaded by Plugin Organizer

  • Hello.

    I have activated the latest version of this plugin and then on the Settings page turned ON “Selective Plugin Loading”.

    I want to turn off a plugin called “Plugin Test” on all Posts, both past and for future Posts.

    So, on Plugin Organizer -> “Post Types Plugin” I have chosen “Plugin Test” and dragged it to “Disable Standard – Not Logged In” as well as “Disable Standard – Default Logged In”.

    So for all Posts so far on the site, that plugin no longer loads on any Post. Which is great.

    BUT, if I make a new Post, then this condition does not kick in and “Plugin Test” does indeed load, when it should not. This is true both for Posts that are being Published immediately as well as Future-dated posts that are published at a later date.

    Can someone please help in fixing this or tell me if there is a better of achieving this…??

    Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    I have tested and this does not happen on any of my installs. Something is interfering with Plugin Organizer on your site. When you create the new post is there a message telling you that the post settings have been set through the post type page or can you see the plugin organizer options?

    Jeff, I can see the “Plugin Organizer” box on the Post edit page after I hit “Publish”. But I don’t see any message.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Are you checking the box to override post type settings when you create the post? Is that box checked after you have created the post?

    Jeff, I am not checking the box called “Override Post Type settings” when creating a new Post. Neither is that box checked after I Publish a post.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Check your database table wp_po_plugins and make sure that the post_type field is varchar(50).

    Jeff, yes, indeed.

    The only way I can get all my new posts to behave like all my old posts (i.e. to ignore that one plugin) is to got to Plugin Organizer > Post Types Plugins and then hit SAVE again in the “Plugins” section. Why is this happening…??

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.