Support » Fixing WordPress » New post won’t publish

  • Hi,

    I’m trying to publish a new post that I wrote about a week about and at the time saved several drafts. Now when I try to publish the post, it doesn’t appear, I am bounced to the front page of my Blog. No error message or anything. The same thing happens when I try to save it again as a draft. I can preview the post ( and it looks fine. I’m not a newbie, been using WordPress for about 10 years and haven’t seen this happen before. I’m not sure what to do.

    • This topic was modified 5 years, 6 months ago by pmorettini.
Viewing 15 replies - 1 through 15 (of 22 total)
  • what is the permalink of the post in the editor?

    possibly try and edit the permalink …

    Thread Starter pmorettini


    I edited the permalink and tried to publish it again, but the same thing happened.

    • This reply was modified 5 years, 6 months ago by pmorettini.

    I have the same problem, I want published a new post, in the administration panel, i create a new post whithout problem, i can see the preview changes, and create finally the post with the button update, the problem is when i go to see the post in the blog categorie where the post was published, and the post is not there, i can’t see the post
    the problem happened after the 2 month after the last ultimated update the wordpress 4.6.1. in the start the update i have published post without problem.

    Do not install any new plugins

    Please i need the help any person, because my business depend the create the new post.

    I don’t know if you guys resolved this issue or not but I found an answer! Had the same problem just now. Couldn’t figure it out, but if you go to “All posts” choose the “Quick Edit” option. From there, you can see the “Status” of your post. Click on the drop down tab, and change it from “Draft” to “Published”. For some odd reason, while creating the post, the published option does not appear for me. Hope this helps.

    I also encountered this problem more than once – sometimes with edits, sometimes with new posts. It took me a long time to figure out why it was happening, but I did finally narrow it down.

    If you paste ANYTHING into the editor window, even plain text sans coding, it disables your ability to publish or save the draft. Simply won’t do it. You’re required to type everything directly into the editor. You’ll get the same result if you have an error in editing custom HTML content for your post. So there’s no more editing elsewhere and pasting it in. Forget it, ain’t gonna happen.

    It’s an issue for me (and how) because it caused me to lose several years’ worth of content. I’m going to try to go back and re-add my old content from the db I saved, but still annoys me to no end. The problem with edits is if you’re going into something older that had pasted content or html errors in the original text. It’s a significant problem and one I hope WordPress developers will look into instead of dismissing.

    I an having the same problems. Trying to publish via quick edit doesnt work either sadly.


    Similar issue. In my dashboard, it actually shows as published (with the date I published it), but when I go to the site, it’s not there. I’ve refreshed the page, still nothing. Tried the quick-edit. It shows a new publish date of today. But still nothing on the site. It looks fine in preview mode. Editing the permalink didn’t help. any advice would be greatly appreciated!

    It’s definitely a post, not a page. If there were a way to add a screenshot, I would.

    Update: I got an automated email from WordPress saying there had been an update. I tried logging out, logging back in and re-publishing the post. No luck. It’s saying it was last published on 4/18/17, but yesterday it said it was last published 4/20/18. Gets weirder and weirder. I just want to publish a post!

    Any updates? I’m having this problem too.

    I’m having the exact same issue.
    Save Draft or Publish …redirects me to the blog home page.
    Preview just opens the blog home page in a new tab.
    When I click my back button, it takes me to the editor with a message at the to: The backup of this post in your browser is different from the version below. [Restore the backup]

    Note: My last post on this blog was 5/29/17 and it worked correctly.

    Tried using Quick Edit and change status to “Published” …click Update.
    The icon just spins. Clicked All Posts…it’s published, but it’s empty.

    the only thing that worked for me was following this instructions

    Hi All,

    I have this same issue. I cant update editted post. It doesnt save the changes. I tried youtube videos ( and cant find any other solution on internet. How could this issue not be solved all these time? Help will be appreciated very much.



    I experience the same problem, it just appeared after the WP 4.8.2 update. Do you have any other suggestion? Thank you.

    • This reply was modified 4 years, 9 months ago by gianr.
Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘New post won’t publish’ is closed to new replies.