Support » Fixing WordPress » New Post – Visual and Code View Gone ?

  • Resolved RossGoodman

    (@rossgoodman)


    Hi

    I recently upgraded to 2.3.2
    I have noticed that when i am creating a new post I no longer have the option of flicking between “Visual” and “Code” view. Is this normal?

    When I do the same on my WordPress.com hosted site I still see the two options.

    Have I done something bad during the upgrade?
    If this a “feature” of 2.3.3?

    Thanks in advance
    Ross
    [sig moderated]

Viewing 15 replies - 1 through 15 (of 26 total)
  • Any ideas?

    Is this normal?

    Nope.

    If this a “feature” of 2.3.3?

    Nope.

    Have you tried clearing your browser’s cache? If that doesn’t do it, I’d suggest re-uploading the WP 2.3.2 files and make sure that you get ALL of them copied up.

    Alternatively, you may have just turned it off. Go to the Users->My Profile page and see if you disabled it. It’s the top checkbox.

    Still doublecheck that you uploaded all the files, of course, but that’s something else to look at.

    Good point, Otto42. I completely spaced that option.

    Similar problem, visual editor does not appear after upgrade from wp 2.3.1 to 2.3.2. It worked without problems on the same server configuration with wp 2.3.1.

    Of course, visual editing is enabled. To be totally sure, I uploaded the tar to the server, extracted it there, deleted the old installation and copied the 2.3.2 files. But it does not help.

    The tabs “visual” and “code” do appear, but no wysiwyg editor in them. It is a simple textarea, and without the controls from the code editor. The problem do occur with the browsers Epiphany and Opera in the newest version.

    The javascript error console from Epiphany says: “editorTemplate has no properties”.

    I could not test it with MS Internet Explorer, because there is no linux version of the IE. Epiphany uses the same engine as Mozilla, but in another GUI.

    I’m sure that it is a bug. It may occur only under strange conditions on the server. If anyone else get the same problem, we should check our webserver’s configurations to find the reason for this problem.

    Make sure that all your JS files are readable by the webserver. At least 444 permissions.

    I have a 644 permission on all files in the wp-admin directory, so it seems not to be a permission problem. But the problem still exists, in WP 2.3.1 the WYSIWYG editor did work without problem, and in WP 2.3.2 it does not display in the textarea of the write post page.

    For me it is not a problem to use the old-style code editor, but it is a blog filled by other people too, and most of them do not understand HTML. Sometimes, it is necessary to create a link in a post…

    (The files are owned by my user account on the server. Of course the directories are readable and executable by all, so the apache can access them.)

    I have the exact same problem…nog solutions so far..

    I’m an idiot !
    Otto42, you hit the nail on the head.
    At the same time as the upgrade I installed OpeinID support.
    In doing this I created a new user for myself.
    Visual editing was switched off for me !

    Thanks for the help !

    Ross

    I could resolve my problem by installing the “Tiny MCE Advanced” plugin. Now I’ve got an avanced WYSIWYG, which is not exactly what I wanted, but it works for me (and hopefully for my co-authors, which is much more important).

    There is still a minor problem. To use the plugin version of the Tiny MCE, I have to deactivate the AdBlocker plugin in my Epiphany browser. With AdBlocker, the JavaScript does not load, but this seems to be a problem in the AdBlocker implementation. With Opera, the plugin works out of the box.

    If you do not have a WYSIWYG editor with 2.3.2, try the plugin. It helps me, and it may help you.

    in fact i also tried this myself but still no visuals. I am not a experienced wordpress user. I actually started a week ago :). Hope someone can help me with this problem.

    I also having the same problem. I installed wp a week ago using fantastico to my bluehost server and then it was working nicely. Then I upgraded to 2.3.2 and now both the visual and code options are not seeing.Yes I have checked the box for visual editor. When I uncheck the same I can only see the codes. Please help!!!

    I installed this plugin http://wordpress.org/extend/plugins/tinymce-advanced/ and now it is working for firefox. but with IE7 still not

    It does not work for me…either in IE7 or firefox.

    I am had a similar problem, but I was able to add a plugin that put in a new WYSIWYG editor. They work, however, the problem is I also have plugins Anarchy or WordPress Video plugin which no longer work in the new WYSIWYG editor. So I can’t add videos and it is frustrating. Please help.

    My blog is http://www.scovilleclan.com

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘New Post – Visual and Code View Gone ?’ is closed to new replies.