WordPress.org

Support

Support » How-To and Troubleshooting » New post problem in version 3.0

New post problem in version 3.0

Viewing 15 replies - 1 through 15 (of 43 total)
  • I’m having the same problem – upgraded various sites – when you add a post, or edit one, it empties the content out…

    to confirm, two different wp installs doing it.. both were a 2.9.2 upgrade

    Here the same problem: updated to WP 3.0,
    tried to write a new post….
    but can’t find the ” Publish” button.

    tried also settings on visible panels, without any result… :'(

    yea, same here. I also can’t find the update button after I edit a post.

    Getting similiar issues, when i click updates in the admin panel i get this.

    Fatal error: Call to undefined method wpdb::get_blog_prefix() in /home/darkre6/public_html/film_reviews/wp-includes/user.php on line 445

    When i click a post to edit or view i get this below.

    Fatal error: Call to undefined method wpdb::get_blog_prefix() in /home/darkre6/public_html/film_reviews/wp-admin/includes/user.php on line 260

    Seems to be user.php.

    I am going to try a re-installation

    Incidentally i am using Suffusion theme which is set up for WordPress 3.0 ( i think )

    my post problem appears to happen without any plugins uploaded/installed, and across any theme, so it looks like either an upgrade issue, or a code issue? Tried re-upgrading, and it still happens…

    Guys I resolved the problem. Just inactive the plugins, it’ll work. So I guess it happened because of incompatible plugins
    and themes…

    cheers

    Taiyab

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    increasing the available memory?

    Ok disabled plugins until i found my problem one.

    Appears to be one of my best plugins, DB Cache Reloaded.

    I will try re-installing that plugin and hope it then works.

    I tried to disable all plugins: still no ‘publish now’ button.
    used the brand new 20-10 theme. -> stil no publish button….

    but… when i switched the view from 1-column to 2-column,
    I saw the publish dialogue and buttons on the righthandside of the screen….

    esmi, yes i have. tried all of that. had a stock 2.9.2 install without any plugins or themes installed, and it’s not working. when i enter anything in the content area, when i save it and go back, the content’s empty – it happens when i create OR edit a page.

    esmi

    @esmi

    Forum Moderator

    Possibly a database issue? Have you tried repairing the database? or re-running the upgrade? Do you have a recent database backup?

    done, done and done.
    it’s two separate sites that are doing it. one’s got stuff on, the other hasn’t – and they are both having this “problem”.

    esmi

    @esmi

    Forum Moderator

    Are they hosted with the same provider? Could it be a hosting issue?

    yes, they are. rebuilding apache just in case.

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘New post problem in version 3.0’ is closed to new replies.