[resolved] New post is empty of content-- newer & older posts are fine (3 posts)

  1. monsley
    Posted 4 years ago #

    Hi everyone!

    I'm having a very strange issue. My second-to-latest post, posted 2 days ago, doesn't display any content. It doesn't show a 404 error at all and the post page does exist: it simply shows the header, featured image and bottom sharing links + footer without any text, images or videos in-between. Checking the post preview I get the exact same result, a page without post-specific content beyond the featured image.

    I started writing a newer post yesterday and that one displays correctly both in preview and on the site. All older posts also display correctly.

    I haven't the faintest idea what to look for. I have checked the HTML-view for the post and nothing stands out, it's all the usual < em > and < strong >. One video embed was made using the XVE Embeds plug-in, and two images were added through the regular WordPress upload & Multimedia archive. Deleting those and attempting repost resulted in the exact same issue.

    I run WordPress 3.3.1 on a shared Hostgator server. The site is http://www.audiofuga.com, though the empty post is currently back in draft form as not to confuse readers :)

    The only plug-in I have added lately was the Envato Toolkit, a plug-in that connects to my Envato account to look for upgrades for my purchased themes. I uninstalled it and attempted a repost, and still the post came up empty.

    Finally, I have run the AntiVirus plug-in, and it has once again brought to my attention that the TimThumb plug-in integrated into my theme uses base64_decode, but I researched that before using the theme and only found confirmation that TimThumb's use of base64_decode is legitimate, so I don't think it's a hacking issue.

    I hope someone can shed some light on this. I'm stumped!

    Thank you :)

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    It could be a server security configuration issue:

  3. monsley
    Posted 4 years ago #

    Hi Esmi, and thanks for the advice!

    A Hostgator tech checked it out and apparently nothing was triggering the mod_security in this case.

    Looking further it turned out to be the XVE Video Embed plugin-- disabling it allowed the content to display.

    Strangely enough other posts which made use of the plugin shortcodes still worked...

    Thanks again :)

Topic Closed

This topic has been closed to new replies.

About this Topic