Support » Plugin: Advanced Access Manager » New Post/edit post no longer working

  • Resolved on4bam

    (@on4bam)


    Since the update of AAM to 5.9.2 adding a new post/page or editing a post/page results in a blank page. Disabling AAM solves this issue.
    Tested in Firefox 66.0.1, WP 5.1.1.

    Edit: Enabling the classic editor seems to work as a temporary workaround until there’s a fix to make the “new” Gutenberg work again.

    • This topic was modified 3 years, 4 months ago by .
Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Vasyl Martyniuk

    (@vasyltech)

    @on4bam,

    Thank you for the message. Seams like some sort of fatal error. Can you please check your PHP error log?

    Let me know what do you see there.

    Thank you!

    Thread Starter on4bam

    (@on4bam)

    Looks like there’s no error log. I’m on shared hosting and searched for all files containing error and .log without success.

    When inspecting the code of the blank page I do see all the code so it seems to load but not display.

    I tried Chrome (clean install, no add-ons) and get the same results. Blank page on Gutenberg but classic editor works.

    Plugin Author Vasyl Martyniuk

    (@vasyltech)

    Oh I see. Do you have RESTful API disabled? https://aamplugin.com/reference/plugin#restful-wordpress-api

    Thread Starter on4bam

    (@on4bam)

    I had it DISabled (as per suggestion) but enabling it makes no difference.

    Exactly same problem here. Enabling and disable RestAPI does not make any difference.

    Same problem here.

    same here. downgrade to 5.9.1.1 and it got fixed.

    Plugin Author Vasyl Martyniuk

    (@vasyltech)

    Hi guys,

    Alright, no worries. Will figure it out however I need a bit of cooperation from you guys.

    First please check your PHP error log. It does not matter if it is shared hosting on not, typically PHP error log is located in the root of your site (where index.php or wp-config.php files are).

    Second – for those who are using Gutenberg editor RESTful API has to be enabled. That is mandatory as Gutenberg uses RESTful API for the editor.

    Third – for those who is familiar with browser developers tool, please check for any AJAX calls that are broken and let me know what do you see.

    This way I might be able to understand what is possible going wrong.

    Thank you.
    Vasyl

    Plugin Author Vasyl Martyniuk

    (@vasyltech)

    Quick update.

    I was able to discover one edge case that causing 403 error and black page with Gutenberg enabled. The response is

    {"code":"rest_forbidden_context","message":"Sorry, you are not allowed to edit this post.","data":{"status":403}}

    I’m working on determining the cause and will release fix ASAP.

    Meantime please keep me updated.

    Vasyl

    Plugin Author Vasyl Martyniuk

    (@vasyltech)

    Hello folks,

    Please check this version https://downloads.wordpress.org/plugin/advanced-access-manager.zip

    The problem was identified and it was related to the fact that I’ve persisted primitive capabilities edit_post, delete_post and read_post in the array of meta capabilities. Long story… and my mistake.

    Please let me know if this helped you all.

    Thank you for the feedback.

    Thread Starter on4bam

    (@on4bam)

    Ok, just came back to the computer, downloaded the new file and installed. 1st impression.. it works.. I haven’t had time to test it but at least “add new post” is working.
    Thanks for the fast replies and fix.

    Thread Starter on4bam

    (@on4bam)

    Spoke too soon… Add new post seems to work (not tested if I can actually write and publish a post but I see the Gutenberg editor)
    Add new post >> blank page.

    edit: New post works and can be published.. that seems to be fixed.

    No error_log in the root of my (shared hosting) or better, no errors logged since Feb 19th.

    • This reply was modified 3 years, 4 months ago by .
    Plugin Author Vasyl Martyniuk

    (@vasyltech)

    Ok. Identified some other issues and updated the code to cover them. Please give a try https://downloads.wordpress.org/plugin/advanced-access-manager.zip

    Thread Starter on4bam

    (@on4bam)

    Installed, quick first glance Gutenberg OK on add new post and add new page.
    Will test further tomorrow.

    Thanks again.

    Plugin Author Vasyl Martyniuk

    (@vasyltech)

    Thank you for the confirmation. I will spend couple hours in the afternoon and dig deeper in the WP core.

    Official release will be posted tonight.

    Thank you all!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘New Post/edit post no longer working’ is closed to new replies.