Support » Localhost Installs » new post do not get displayed in the output

  • Resolved luit74

    (@luit74)


    Hi i’m Luit, i shall be gratefull if anyone can help me out .

    Actually i’m using a local host name LOCAL BY FLYWHEEL, in which I’m not being able to output the have_post wordpress function. I’ve been learning W.P from an online course in which the guy asked us go and edit in local>wp_content>theme folder to have an output after doing all the typings If I go to the wp_admin>post>add new , and add some post there , I’m not being able to output all of the post available even after using the while loop . Only one post get displayed on the screen , the post which is already by default present in the WP system , the post that I have added can’t be seen in the output

    This is the code guys please correct me if I’m wrong somewhere.
    <?php
    While(have_posts() ) {
    The_post(); ?>
    <H1> <?php the_title(); ?> </H1>
    <?php the_content(); ?>
    <Hr>
    <?php
    }
    ?>`

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter luit74

    (@luit74)

    i’m stuck for many days . today is day 4th and its still counting. help me out please.

    Do the post appear in other displays, pages which use regular templates from your theme rather than ones you wrote yourself ? Say the categories one.
    Are the posts published etc, just like the demonstration post ? Open the demo and one of yours in the posts editor and see if anything is missing or different.
    Add some of your own output so you can see that your template is really getting accessed, something like: <php echo '<p>Location A</p>';?> and so on.

    • This reply was modified 1 month, 1 week ago by RossMitchell.
    • This reply was modified 1 month, 1 week ago by RossMitchell.
    Thread Starter luit74

    (@luit74)

    @rossmitchell yes the post do appear in another tab if we preview it, and it also get published but when i want to view it in the main front of the website it does not appears only the post which is already exist in WP can be seen

    Thread Starter luit74

    (@luit74)

    @rossmitchell hi mitchell thank you now i can see all the post at a same time but i got another problem i cannot see the content now. please help me out

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.