Support » Plugins » New Pluign: Faked Folders

  • Hey guys, long time! 🙂
    Anyway I’ve got a new plugin for you to try: Faked Folders. It’s supposed to be my idea of static-posts done right…

    • Creation of pseudo-folders for easier management.
    • Custom templates.
    • Enhanced plugin support allowing you to choose which plugins are activated for which folder.
    • Supports comments in static-posts, allowing for quick guestbooks and such.

    And more I’m sure once people start using it. Let me know what you think!

Viewing 15 replies - 31 through 45 (of 62 total)
  • ieure: What was causing the implode error? I developed this using PHP 4.3.6, so I should have recieved that too, right?
    And everyone else: It seems the Guvner bug is immortal and there is no stopping it. However I’m working on 2.1 right now and that will have better debugging support for eliminating that meddlesome bug. 🙂
    Also expect a better upgrade script (because the current one seems to be as useful as toast) and a “view page” method so you don’t have to worry about where your pages are.
    all these bugs and requests… how can i ever expect to get this documentation done!?! 😉

    Stevarino: I tried emailing you with the patch yesterday, but it looks like I sent it to the wrong address. I will resend it, if you like. In short, PHP < 4.3.0 requires two arguments to implode(), and it is not recommended that you use the >= 4.3.0 syntax. PHP’s implode() documentation gives you a bit more information.
    I actually got things mostly working by just ripping out the tempfile code and forcing it to use tempnam(). Not an ideal solution, to be sure. I can now access my static pages if I go to the real URL; that is, http://www.mysite.com/index.php?static=true&name=test
    I have had no luck getting the Rewrite rules working so I can go to /Static/test/. Is there something I have to do to tell mod_rewrite that RewriteRules are allowed in a .htaccess file?

    Oh, and I’m quite sure that changing the ini_get() statement didn’t work for me.
    It looks like I simply can’t use mod_rewrite in .htaccess files. I’ve tested it, and none of the rules in there are ever applied. There has to be some magic to enable that – anyone know how to do it?

    TheMole: It should be /folderName/postSlug
    E.g. if you create a ‘Static’ folder, and add a post to it called, ‘foobar’, the URL would be http://www.mysite.com/Static/foobar

    ieure: This is really why I need to get to documentation. I mentioned support for non-.htaccess weblogs. The trick is this: simply put “index.php” between your wp-install directory and your static file.
    An example:
    Your regular weblog is at “http://domain.com/blog/”. You create an about page using my plugin, and its URI should be “http://domain.com/blog/about/”. To get the same effect without using rewrites, try the domain “http://domain.com/blog/index.php/about/”. It looks like a normal redirected domain, but functions like a query string. 🙂
    And thanks for the assistance with the support Guvner and ieure. One small note to what ieure said: if you want you could set “foobar” to be the folder’s index, in which case the uri would be http://mysite.com/static/

    Oh, and thanks for the heads up ieure. To be honest it was a typo on my part that implode was coded in that way, I didn’t even know that the string was optional! It will be fixed in 2.1, promise.
    And my email is steve at stevarino with a dot and a com. Feel free to email me any suggestions, fixes, questions, whatever. 🙂

    Stevarino: No worries. I saw your correct address in your profile here, but I wasn’t able to find it on your blog anywhere. The patch I linked above is the same one I sent you. The database creation is the more severe of the two issues, anyways.
    I’d really like to get the rewriting working, but it’s not a huge deal. I really only need one static directory, so I just modified the rule and added it to my Apache config.
    This plugin could definitely use some polish, but I have it under control now.

    Now I’m, scared, the error pages are working fine for me, but I can’t resist the temptation to update. Damn, another day at work spent doing something I shouldn’t then.

    Heh heh. You can stay with the version if you want, but I THOROUGHLY tested the code that was giving you trouble. And I did find a few bugs here and there, so I recommend giving it a shot. 😉

    Documentation is now available. Whew!
    Also I’ve included some screenshots because I know some people dig those. 😉
    btw, all those pages were created with Faked Folders.

    Um, there are no redirects in Faked Folders. Where are you getting these?

    database tables are ok. Ik kan maken the folders, and put a draft in it. Then the draft is clickable, with the url. When I click on it, then I get the redirect error.
    A simple explanation, i hope you understand me 😉

    Yah, I think I get it now: it only appears when you try to view a page. I’m just a bit confused with why it’s giving you errors.
    What is the hyperlink’s address before you click on it (right click and select “Copy Target” or something similar)? What is your normal weblog URI?

    Cool, thanks… The problem is that the page is coming up 404.
    Then when it tries to load your error page: http://www.dextrose.be/errorpages/404.html it goes into a loop. Your error page is calling your error page. :\
    Not sure what’s causing the second problem (you can email me and we can work it out if you want), but the first seems pretty easy. I notice that in your weblog you don’t use pretty-urls, they all use the index.php?p=x URI. I’m not sure if your weblog can handle a .htaccess file, but regardless this can be fixed.
    In the faked-folders main page where you see a listing of all your folders, scroll to the bottom. You should see a button labeled “Disable Mod-Rewrite.” Click it. Now your links will work:
    http://www.dextrose.be/index.php/wordpress/about/about
    There is an error there, but try following the instructions it gives. Create a file called fakedfolders.txt and chmod it to 666. Then try it again.
    If you have any more trouble let me know! 🙂

Viewing 15 replies - 31 through 45 (of 62 total)
  • The topic ‘New Pluign: Faked Folders’ is closed to new replies.