The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

New plugins now showing in Plugin Dashboard (12 posts)

  1. dennisbp
    Posted 9 years ago #

    I've used WordPress for several years now and this is the first time I'm experiencing problems with the plugins.

    Last night I installed the "Google (XML) Sitemaps"-plugin and it worked great. Today I wanted to install Matt's Random Page-pluing and it doesn't show up in my plugin dashboard. I try to upload another plugin - same problem.

    Then I try to delete and old plugin - it disappears on the dashboard, as it should, I re-upload it, but it doesn't reappear on my dashboard.

    I can active and deactivate plugins just fine.

    Thank you in advance for any help and answers.


  2. Glenn Ansley
    Posted 9 years ago #

    make sure the plugin's core .php file is only one directory deep. eg: wp-content/plugins/plugin.php or /wp-content/plugins/pluginname/plugin.php.

  3. dennisbp
    Posted 9 years ago #

    I've tried with both solutions. Same result - nothing :-/

    I've used and upload several plugins in the past without any trouble. What concerns me most is when I delete and existing plugin and reupload it doesn't appear on the list.

  4. Glenn Ansley
    Posted 9 years ago #

    Do you work with two blogs or a dev site? I know it sounds simple, but make sure you're uploading to the correct domain or site folder.

  5. dennisbp
    Posted 9 years ago #

    No I'm only working with one domain and no other sites.

    I have a bookmark in my ftp-program.

    Thank you for taking the time to help me so far :-D

  6. Glenn Ansley
    Posted 9 years ago #

    What happens when you type the following into your web browser:

    If the folder doesn't exist, you'll get a 404. If it's there, you'll probably get some type of access denied error. Try it for one that is working and for one that isn't working. It really sounds like your files are there and this will determine that.

  7. dennisbp
    Posted 9 years ago #

    I tried with http://www.petersen-inc.dk/wp-content/plugins/all-in-one-seo-pack
    and got right on my blog. No matter what folder I type.

    I'm 100% sure that the plugins are there. No doubt about that at all ;)

  8. Glenn Ansley
    Posted 9 years ago #

    What plugins are you trying to upload?

    I thought we had confirmed this already, and you probably have, but they're unzipped prior to upload, correct.

    At the bottom of your plugins page in admin, does it say anything about broken plugins?

  9. dennisbp
    Posted 9 years ago #

    They are already unzipped.

    As mentioned before as a test I removed an already working plugin. I deactivated it, downloaded it locally, deleted it on the server, reuploaded the plugin again and it didn't appear on my list even though its in the same folder as it was before.

    I've uploaded several plugins about 30 altogether the last couple of years without any problems.

    I tried to use a plugin written by WordPress' founder himself ;)

    So that should work. I've seen it on other sites where it works great.

  10. dennisbp
    Posted 9 years ago #

    oh and I just noticed the link I gave you earlier is wrong.


    This is the right one. As you can see I get the access denied error, but the pluing isn't showing.

  11. dennisbp
    Posted 9 years ago #

    and the last thing...there is no message about broken plugins

  12. dennisbp
    Posted 9 years ago #

    Blepoxp: I've got it!

    It turns out my ftp-program (flashfxp) didn't transfer the files corretly. I'm still trying to find out what is wrong.

    The programs tells me that it trasferred a 7 Kb file but when I look at it its blank (0 bytes). I tried to use my hosts web based upload and the plugin shows.

    Its a stupid mistake and I really appreciate all the time and effort you put into this.

    Thank you very much! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic