Support » Plugins » New Plugin: XHTML Mime-Types

Viewing 11 replies - 1 through 11 (of 11 total)
  • “XML Parsing Error: not well-formed Location: http://www.websprockets.com/index.php?p=35#more-35

    Maybe I should have called it “Invalid XHTML & WordPress.” :^P
    Fixed now.

    I should do a proper write-up for this, but I use something similar:
    http://www.stijlstek.nl/greek2me/src/headers.phps

    I have rewritten and repackaged my solution:
    http://stijlstek.nl/greek2me/src/xhtml-or-html-0.2.tar.gz

    I tried this on the latest cvs version.
    grep -R "text/html" * returns no hits in my wordpress files except in the plugin. The meta tag says it is application/xhtml+xml but the server still sends the header Content-Type: text/html; charset=utf-8. What might I have missed? It worked in a previous version which I think was similar to alpha-3 or so.

    The meta tag is useless here, it doesn’t force anything. You must send the right headers with PHP. Have you followed the instructions?

    The addition of a http_head hook is really nice.. I think that should be folded into 1.3, the more hooks the better.
    I really like this plugin – its elegant and simple, and doesn’t rely on dodgy user agent strings.. which is such an outdated method that I can’t understand why people would still use it.
    Plus it doesn’t mess with anything else that what it says.. unlike similar solutions.

    I know it won’t do anything and because I could not get it to work, I asked here. I have followed the plugin instructions but that still does not give me a proper Content-Type http header sent except text/html in the most recent cvs version. I guess I missed something obvious.

    If I send

    GET / HTTP/1.1
    Host: www.cdr.se
    Referer: http://www.cdr.se/index.html
    User-Agent: Whatever
    Accept: application/xhtml+xml
    TE: identity, chunked
    Connection: close
    Date: Wed, 15 Dec 2004 15:59:01 GMT

    the server replies with

    HTTP/1.1 200 OK
    Date: Wed, 15 Dec 2004 14:56:10 GMT
    Server: Apache/2.0.52 (Gentoo/Linux) PHP/5.0.2
    X-Powered-By: PHP/5.0.2
    X-Pingback: http://www.cdr.se/xmlrpc.php
    Connection: close
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8
    X-Pad: avoid browser bug

    I see no Last-Modified, ETag or similar sent out though. No staticize or similar exists.

    Unfortunately I don’t remember why this stopped working. I don’t think Apache2 has anything to do with it, and I can’t think of any change I’ve done to Apache2 or php that would affect it. The problem seems to be somewhere in WordPress. Anyone got got it working who can provide feedback?

    I somehow managed to edit the wrong branch of the condition in wp-blog-header *blush*. I also managed to forget my password and can’t seem to find a way to restore password for these forums.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘New Plugin: XHTML Mime-Types’ is closed to new replies.