Support » Plugins and Hacks » New plugin: Flashfader (slideshow in flash)

New plugin: Flashfader (slideshow in flash)

  • Hi all,

    I just finished my first plugin. Flashfader 1.0
    It allows you to put a flash slidehow on your site.

    Upload 2 files in your plugins directory, add one line to a template page and its up.
    Upload of images and configuration (size etc.) via the admin panel.

    download , Flashfader homepage


Viewing 15 replies - 1 through 15 (of 27 total)
  • I love the Plugin but question, where do I place the images?

    link is dead to download


    Trac detected an internal error:

    ‘module’ object has no attribute ‘cgi_start’

    Traceback (most recent call last):
    File “/usr/home/matt/cgi-bin/trac”, line 25, in ?
    AttributeError: ‘module’ object has no attribute ‘cgi_start’

    I put up an additional download.

    I am not sure what you mean with “place”.
    If you are asking how to put the flash on the frontend of your site, you have to edit the sourcecode of one of your template pages. Did you follow the instructions in the how_to_use.txt ?

    Yes I followed your ‘how_to_use.txt’ but after uploaded them images and made it writable, it gave me these errors:

    Warning: main(/home/forcefor/public_html/wp//wp-content/flashfader/flashfaderhtml.txt): failed to open stream: No such file or directory in /home/forcefor/public_html/wp/wp-content/themes/mx4_theme/sidebar.php on line 3

    Warning: main(/home/forcefor/public_html/wp//wp-content/flashfader/flashfaderhtml.txt): failed to open stream: No such file or directory in /home/forcefor/public_html/wp/wp-content/themes/mx4_theme/sidebar.php on line 3

    Warning: main(): Failed opening ‘/home/forcefor/public_html/wp//wp-content/flashfader/flashfaderhtml.txt’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/forcefor/public_html/wp/wp-content/themes/mx4_theme/sidebar.php on line 3

    try to change the code in the sidebar to

    <?php include (ABSPATH.’wp-content/flashfader/flashfaderhtml.txt’); ?>

    (remove the / before wp-content/flashfader…)

    this is an awesome plugin thanks much

    I did thought that was the case but it still didn’t work thats why I’m searching for advice or perhaps its taking longer to refresh. I might need to clean my cache over and over. Yes I’m at that point.

    Makki. Did it worked for you the first time? Or you had to edit few lines?

    If you changed the code in the sidebar (the / was a bug/typo) and the error message does not appear anymore, this problem seems to be solved.
    Must be something else. Can you provide a link?

    I installed the plugin and activated and inserted code into sidebar and worked first time

    here is my code i used in sidebar

  • <h2>Pixels</h2>
    <!– Flashfader –>
    <?php include (ABSPATH.’/wp-content/flashfader/flashfaderhtml.txt’); ?>
    <!– /Flashfader –>
  • My site is here makkistudios.com


Thank you for replying and your help. I just now got home. I retry from scratch. Seems to be working but image is not displaying. Went to my control panel to change it to writable and waiting…


Thanks Makki. I had to the same exact line but for strange reason it’s not working for me.

I have time before bed to poke on it a little. Thanks all and g’night. Cheer.

I know the reason. Look in the images.xml file.
The paths to the images are not correct, there is a / missing. The / is in the script. Did you edit flashfader.php and removed it accidentally?
the line is: $out .= ‘<image path=”‘.get_settings(‘siteurl’).’/wp-content/flashfader/’.$value.’.jpg” />’;

No sir I did not.
I only edited the <php script line for Sidebar.php then after I saw the error “//” I went and edited images.xml. I can say there was no more errors but now the image are not displaying.

I have time to troubleshoot some more today. I’ll see what I can come up with.(Yeah right)



well, you shouldnt have edited images.xml 🙂
Go in the flashfader admin, just press save in the display settings. that rewrits the images.xml if its still writeable, because you uploaded a new one. or just change permissions to 777 before

Ok. I gave up.

I destalled the plugin and downloaded your new updated one after that small fix.

Made ALL of them 777.

Working now. Thanks a bunch!

Is there a problem with running this plugin when PHP is running in SAFE MODE?

I am having no end of difficulties running this. I copy the two files across to the wp-content/plugins directory, makes sure that the the whole wp-content folder has full permissions, including the two flashfader files.

I then activate flashfader from Plugin Management page. However, when I go to the Manage and Flashfader, I get a load of error messages …. including something about Safe Mode and others which are basically saying that flashfader wasn’t able to create the various .txt files in the flashfader folder. Oddly, it does manage to create the flashfader folder however.

I don’t really get as far as modifying the sidebar.php file as I thought it wasn’t working correctly. Would doing this fix the errors?

Am I doing something wrong, or is it that my ISP’ web-server set-up simply doesn’t agree with flashfader?

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘New plugin: Flashfader (slideshow in flash)’ is closed to new replies.
Skip to toolbar