Support » Plugins » New Plugin: CommentLuv – luv your commenters!

  • I’ve made a new plugin called CommentLuv to spread the luv to your loyal readers!

    CommentLuv appends the authors last blog post to their comment before saving it to the database. It can parse a WordPress, Blogspot or Typepad feed found in the default location, if one doesn’t exist there, it parses the comment authors page for a feedburner feed and uses that instead.

    version 0.8 is available at

    I made it with WordPress 2.2 in mind, it’s been tested on a few different blogs and it’s working well!

    just download, unzip, upload, activate. no template editing required.

Viewing 15 replies - 16 through 30 (of 42 total)
  • I don’t use this plugin but I surf blogs that do. I want to like it but it never, and I mean NEVER succeeds in getting my latest feed. If it works at all, then it’s always grabbing a post I made days weeks, even over a month ago rather than my latest entry. I think it has a problem with blogs which use the FeedSmith plugin to redirect their feedburner feeds. That’s my guess at least.

    I downloaded and installed the plugin today … but commenters are getting this error when they post a comment.

    Warning: comment_luv(/home/httpd/vhosts/ failed to open stream: No such file or directory in /home/httpd/vhosts/ on line 169

    Warning: comment_luv(): Failed opening ‘/home/httpd/vhosts/’ for inclusion (include_path=’.:/usr/local/lib/php’) in /home/httpd/vhosts/ on line 169

    Fatal error: Call to undefined function: fetch_rss() in /home/httpd/vhosts/ on line 226

    Any suggestions?

    I’d love to be able to use it?

    *Apologies in advance if this is an obvious problem … I am not very good at this stuff!

    Your blog is less than 2.1 so it doesn’t include the magpie functions and that’s what is causing the error. The version I sent you has a folder with the includes but I think that also sometimes gives errors.

    Sorry about that! hopefully your host will updgrade their wordpress scripts..


    There is a problem with your plugin with special charaters.

    “Tr�s dicas para rentabilizar um feed” from my feed at, for example.

    Can you do something about this in the next realease?


    CommentLuv doesn’t pick up my feed. I can’t figure out why! I’m using a WordPress platform, on my own server. 🙁

    @teamplaylotto: regarding stshores24 post about WP still adding the nofollow attribute – you pointed out that the source code of the page will reveal there is NO nofollow attrib. you are correct. is that what the search engines see? as the whole point of the “nofollow” movement is to avoid WP’s nofollow. Sorry if I’m not clear.

    yes ocmega, search engines see exactly what you see when you click “view source” on a page (unless you have special code for spiders and bots).

    I’ve been using this plugin for a short while and love it. However, I have noticed that it adds in the nofollow code, despite the fact that I am using (the latest version of) Denis de Bernardy’s DoFollow plugin.

    Any chances support will be added soon for this plugin?

    I made a comment on your blog and checked it for nofollow and it didn’t have it. You may be seeing the nofollow bit when you get notified of comments by email or within the WP admin section but if you check the source of the page itself then you will see that the comments are do follow

    thanks for spreading the luv!

    Hrm, you’re right. It shows it if I edit a comment, and it shows in the email alerting me to new comments, but it’s no longer actually ON the site. Thank you for clearing this up. 🙂

    I changed the add_text() function to comment_luv_add_text(), modifying it in such a way that the “Enable CommentLuv” checkbox can be manually added to a theme anywhere in the comment form above the do_action() call. You can see the modified plugin code here:

    I borrowed the idea/method from the Subscribe to Comments plugin. I’m now including the CommentLuv bit in my theme with this code:

    <?php if (function_exists('comment_luv_add_text')) { comment_luv_add_text(); } ?>

    That’s added in my theme’s comments.php file, just above the HTML for the comment form submit button.

    Just thought I’d share, in case anyone else finds that useful.

    I love this plugin! My question is just a cosmetic one…is it possible to put a space or line between the end of the person’s comment and the commentluv information? I tried various things but none of them were effective to place a space or line in the right spot.

    Thanks for your hard work!

    I’ve just switched to a new theme – and now new Comment Love isn’t appearing, nor is the notification. Being that I really only understand the bare minimums of css/html, could you please take a look and let me know how I can run it, again?

    Thank you.

    I installed this, and added a bit of text (scroll up just a little to see it) to the comment area to encourage posting comments, this plugin was a great idea! Thanks!


    I added a paragraph tag on line 297 as shown below, and it seemed to work, HTH!

Viewing 15 replies - 16 through 30 (of 42 total)
  • The topic ‘New Plugin: CommentLuv – luv your commenters!’ is closed to new replies.