WordPress.org

Support

Support » Plugins and Hacks » [New Plugin] Alexify

[New Plugin] Alexify

Viewing 15 replies - 1 through 15 (of 22 total)
  • interesting. after the impressions limit is reached, i guess IE users get the big red X?

    HI,

    No idea. My blog isn’t nearly busy enough to hit the limit. However, I am thinking about adding PHP code to cache the images locally and use them if available. Since the blog entries are static, the first view of the image could potentially download and save them image. future views could see the saved images was available and use it instead of bothering the wonderful folks at alexa.

    =C=

    for anyone (like me) who had no idea what they’re talking about, LOL

    hold your mouse over links on http://blog.calevans.com and a nifty little screenshot pops up

    Sorry I didn’t make that clear in the original post. Yes the plug-in inserts a small amount of JavaScript into the head of your page and then modifies each anchor tag to add a mouseOver and mouseOut function. It also ads a hidden div tag to the bottom of your page.

    The mouseOver function inserts a image tag into the hidden div tag that is a link to alexa.com’s thumbnail generator. Then it makes it visible. The mouseOut just makes it invisible.

    Simple code but I like the effect.

    =C=

    UPDATE:

    I just upgraded to WP20 and wp-alexify works just like it did in 1.5. I did find that if you put a title tag in your anchor tag that it overrides the popup.

    =C=

    Update:
    1.0 01/30/2006 – Cal
    Removed the code that limited this to the main page. It should now work in all WP pages. Thanks to Thomas-DK to pointing this out to me.

    Project Page:
    http://www.calevans.com/view.php/page/alexify

    =C=

    computerfriend
    Member

    @computerfriend

    Hey, Cal,

    We really like your plugin Alexify, and it works great for any link on the main part of our website as long as the link fulfills two criteria:
    1. It must have the name of the link as the link ( such as ” http://www.apple.com ” ) but it won’t work with ” Apple.com ” which is linked to that site. We’ve tried it with several big named companies and it has that same issue with all of them.

    2. The link must open in the same window as our blog. If the plugin runs into any html which tells the link to open in a new window, no thumbnail will show up, but as sure as the _blank tag is removed, the thumbnail works fine.

    Also, none of the links on sidebars work with this plugin. At least not on our site, which is http://www.artondisk.com .

    Do you have any plans to work on this or does anyone know of a workaround that can fix these issues? We really like the concept and think your idea is great. Thanks! Richard Nichols

    @computerfriend,
    Can you give me your blog URL where I can see these issues? The sidebar issue is not a bug, the plugin only registers to work on posts. I’ll look into allowing it to work on the sidebar as well.

    If you check out my site you’ll see the current development version of the plugin. It doesn’t fix any of the issues you named but it does fix the stuttering image problem and it’s compatible with Safari.

    I have a feeling that #2 is related to the regex I use to find the A tags. I’ll look into that. (Although I’m no regex expert.

    #1 must be something else. If you look at my site you’ll see that I rarely name the links the complete URL. (There are probably 20 on my home page alone.) Again, if I could see your blog maybe I could get a better understanding.

    =C=

    computerfriend
    Member

    @computerfriend

    Hi Cal,
    My site is at http://www.artondisk.com . A good example of where the plugin works on one hand and not on another is at this permalink:

    Advertising & Marketing

    As you will notice, there are a number of links on the page to various well-known sites but the only link that shows a thumbnail of a site is the one just below Flickr. It is a link to Android Technologies. For some reason, it works fine, but Flickr doesn’t and neither does Webopedia or Wikipedia.

    Anyway, this is a very cool idea and I don’t really expect you to spend a lot of time figuring it out, but if you happen upon the solution, my email address is computerfriend@hotmail.com or you can contact us through the artondisk.com site. We are still working on this so it isn’t a fully functioning site yet. In other words, we haven’t announced it to the rest of the world until we get most of the stable content in place.

    Thanks!
    Richard at Art on Disk Corp.

    UPDATE AVAILABLE:
    2.0 is now available. This fixed the stuttering image problem and should be compatible wit Safari. (I look forward to someone confirming that)

    Project Page:
    http://www.calevans.com/view.php/page/alexify

    It can be downloaded there. Please read the Upgrade instructions if you are currently running alexify.

    As wlasy, questions or comments welcome.

    @computerfriend,

    Can you try this version and see if it works any better?

    =C=

    computerfriend
    Member

    @computerfriend

    Thanks for trying this for me, Cal. I am no expert when it comes to these things. I usually un-tar a file using WinRar on my Windows XP PC. In this case, I un-tarred your file, and found one file inside it called wp-alexify which I renamed “wp-alexify.php” and copied it into my wp-content/plugins/ folder in WordPress after de-activating and uninstalling the alexify.php file I was using before.

    While I can see your plugin just fine inside my WordPress console, when I activate it I get this message: plugins/blogbling/wp-alexify.php0100644000100100010010000001472410373742762017444 0ustar calevanscalevans

    Now, to begin with I don’t know how to un-tar a tarball any other way than I am but so far it has worked every other time I’ve tried by just untarring it into a folder on my desktop and then ftp-ing the file or files whereever they need to go.

    However, I don’t want to waste your time (in the same way all my clients waste my time) by not following directions in the first place. Maybe I will go back and re-read your instructions and see what I can do differently, because I am missing something. Again, thanks. This will be great when I get it working right and I’m sure my blog readers will like it too. Richard at Art on Disk …

    @computerfriend,

    The new version goes in a new directory under the plugins dir and expects some things to be in that dir with it. Try this:

    http://www.calevans.com/wp-alexify.zip

    That should unzip with any Windows zip utility all the files are in a subdriectory blogbling. Put the blogbling directory in your plugins directory. There should be 4 files in the zip file:
    blogbling/wp-alexify.php
    blogbling/blogbling_functions.php
    blogbling/images/blogbling.gif
    blogbling/js/wz_tooltip.jz

    To upgrade:
    1: Deactivate Alexify
    2: Remove the current plugsin/wp-alexify.php
    3: place the above files in your plugins directory.
    4: Activate wp-alexify 2.1
    5: Go to Options and you should now have an alexify options page.

    Let me know if this works. If you have AOL IM, feel free to ping me there VirtualCIO.

    =C=

    computerfriend
    Member

    @computerfriend

    Hey, Cal,

    Ok, I did try this out and it doesn’t give me any error messages but I am still not able to see most of the links as thumbnails. We are such wuss’s here– we don’t want people to navigate away from our blog so we make all or most of the links open in a new window, but that seems to be why it doesn’t work. I tried it on our Macs as well as our PCs. Safari pretty much shows us the same phenomenon, it can make a thumbnail as long as the link isn’t going to open in a new window.

    You can visit our test site at http://www.artondisk.com/backroom and see your plugin working for a number of the links down the page, but then when it gets to cnn.com it stops, because that opens up a new window.

    Anyway, this is interesting technology and I appreciate your efforts, whether in the final analysis we get this working or not . . . Thank you! (sorry, I don’t have AOL messenger or any IM). Richard at artondisk.com

    Richard,

    Ok, this sounds stupid but try something for me. On the A tags I looked at on your site there was a space between the target=”_blank” and the closing >

    Try removing that space. Make it:

    target=”_blank”>

    Let me know if that makes any difference.

    =C=

    computerfriend
    Member

    @computerfriend

    Cal, oh, nothing sounds stupid when it comes to this stuff. Tiny mce or whatever that wysiwyg feature is called, adds all kinds of strange html to our posts, making it especially difficult to add photos and keep them centered and in position (it adds a lot of extra p and /p tags for no good reason). I was hoping that would be fixed in the latest iteration of WordPress but since I never complained about it I guess I’m the only one with the issue.
    We are using a theme called Jakarta, but we have modified it a great deal. This issue might just be with our site and not with other themes.
    I tried your suggestion but when I go into the html there isn’t a space there, and any spaces I did find, such as before the word “target” I took out. It didn’t make a difference.
    So here’s a random thought– there’s a website at http://www.sitepoint.com/article/beware-opening-links-new-window where the author recommends never opening things in new windows in the first place as it annoys visitors. I hadn’t thought about that. We don’t like using our “back” button any more than we have to but maybe the answer is for us to quit having things open in new windows.

    Personally I like having links open in new windows because I don’t want to lose what I was looking at in the first place, and often when I try to get back to where I was something stops me or resets the back button anyway.

    I’ll think about this some more. In the meantime where we really do want the thumbnail to work, we will let the link open in the main window. Thank you for trying so hard to make this work.

    Richard

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[New Plugin] Alexify’ is closed to new replies.