New Pictorialis install: problems (7 posts)

  1. Damian
    Posted 11 years ago #

    I've installed WordPress successfully and the Pictorialis hack largely successfully. I'm having one problem: the full size images aren't going to the /upload folder that they are supposed to be in, but rather to a sub-folder off of the wp-admin folder.
    This wouldn't be a problem if I could figure out how to change the path to that folder, but I haven't sorted that out yet.
    This is the error message I get:
    "The requested URL /upload/051704bw1.jpg was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. "
    This is my (under construction) photo log: http://opaque.ca

  2. Damian
    Posted 11 years ago #

    Ah, I sorted it out and found the correct path, but had to go through and manually edit my posts to correct the path on previously posted images. Was there any way I could have avoided that?

  3. w8in
    Posted 11 years ago #

    Can you tell me how you've fixed the problem? I have the same issue.

  4. Laughinglizard
    Posted 11 years ago #

    The upload folder needs to go into the root of your pictorialis blog and the setting in wp-admin/post.php should reflect that same folder. In many cases, the post.php is referring to the wp-admin/upload folder. This setting is for the $UploadDir variable as mentioned in the readme. If the readme is wrong, please let me know and I will correct it.

  5. w8in
    Posted 11 years ago #

    Thanks, LL, that worked!
    I really think you did a great job on this.
    The readme says this :
    3) Open post.php in your wp-admin folder and edit it.
    Find this line and replace it with the real path of your upload directory you
    just created.
    $UploadDir = 'Replace with the path to your upload directory, dont forget the trailing slash';
    Like in this example:
    $UploadDir = '/home/httpdocs/pictorialis/wp-admin/upload/';
    Dont forget the trailing slash

    In Step 2 of the readme you have us create 3 folders in wp-admin, one of which is a folder called "upload". I don't see anything happening in that folder and maybe you meant to create the "thumbnails" and "images" folder in "/wp-admin" and the "upload" folder in the root of the blog?

  6. Laughinglizard
    Posted 11 years ago #

    You are right. I will fix the readme when I get a chance. Sorry for the trouble.

  7. Laughinglizard
    Posted 11 years ago #


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.