Support » Plugin: WordPress Native PHP Sessions » New PHP warnings

  • Resolved jgriffin783

    (@jgriffin783)


    Hi,

    After updating to wordpress 5.1, php warnings began to log for this plugin on our site. Here are the warnings:

    PHP Warning: ini_set(): Headers already sent. You cannot change the session module’s ini settings at this time in /wp-content/plugins/wp-native-php-sessions/pantheon-sessions.php on line 131
    PHP Warning: session_set_save_handler(): Cannot change save handler when headers already sent in /wp-content/plugins/wp-native-php-sessions/pantheon-sessions.php on line 141

    I spoke with pantheon support and they said that this error is usually due to php version incompatibility (we’re on 7.2), but in our instance it only occurred after updating wordpress to 5.1 and was working prior. They recommended reaching out here to see about whether or not this was a known issue with a fix coming, or if it was something isolated to our environment somehow. Any help here would be appreciated.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘New PHP warnings’ is closed to new replies.