WordPress.org

Support

Support » How-To and Troubleshooting » New pages not displaying

New pages not displaying

  • Using the standard WordPress Admin dashboard, trying to add pages (example – http://full.thetaters.com/music), and all seems fine in WP dashboard (no error messages). But the pages don’t seem to be there when I try to “Visit Site” or just view the URL. I get the following error:

    Not Found
    The requested URL /music/ was not found on this server.
    Apache/2.2.14 (Ubuntu) Server at full.thetaters.com Port 80

    Do you know of anything i might be doing wrong? Again, within the dashboard, the page is showing as published.

Viewing 11 replies - 1 through 11 (of 11 total)
  • How many different page names have you tried?

    Asking because the only time I have seen this I tried to make a page with the exact same name as something in my media library and it gave me that error.

    Aaron,

    hadn’t tried many others, so good thought. I just tried changing the page name to “test2”, but no change.

    What’s also interesting is that the navigation menu shows the name of the created page – even changed it to “test2”, but you just can’t see the page if you go to it…

    Change the permalinks back to default and test it.

    OK, that seems to have worked, thanks! Don’t know that I understand why, though… will I have to keep the permalinks at the Default style permanently?

    Without fixing it you will need to keep it like that.

    But it seems you have a permalink problem. First thing I’d try is deactivating all plugins then testing again.

    Can check your .htaccess file to make sure it has the below in it

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    OK, thanks, I’ll give all of this a try.

    I appreciate the help!

    Looks like my .htcaccess file has just these lines in it:

    DirectoryIndex index.html
    RewriteEngine off

    Where should I add the code block that you included? AFTER these 2 lines?

    Just replace it all so it looks just like I pasted above.

    OK. Don’t know if this is connected, maybe a problem at my host end. When I try to edit the .htcaccess file and upload it (using Filezilla, as i have for other items), i get

    Critical file transfer error

    and it doesn’t upload. I checked the file permissions on the remote copy, and it has Read & Write enabled, but it won’t take the upload, or let me edit it (remotely) directly.

    Might want to contact the host then. Does your hosting come with a cPanel or something similar you can edit the file through an online file manager? Might want to try that also.

    Or you can try an online FTP program and edit the file directly. The safest one to use is at dreamhost.

    https://webftp.dreamhost.com

    Thanks, I’ll check with the host and also take a look at dreamhost.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘New pages not displaying’ is closed to new replies.