Support » Plugin: WP Advent » New Page opens inside Glightbox / iframe

  • Resolved The-Dude

    (@the-dude-1)


    Hi,

    if i dont activate the “Open in new tab”-Option in the image options, the linked page opens inside the iframe of the lightbox / glightbox. This is not usefull. It would be better if a click on the image opens the linked web page in the whole browser window or tab.

    Could you please fix it, offer an option in the backend or at least give me the code snippet so I can add it myself? 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Dominik Schwind

    (@dominikschwind-1)

    Hi,

    well, it’s the whole concept of the plugin that the day sheets open inside the lightbox. I’ll put it on the list of feature ideas for next year, but we won’t do any conceptual changes this year.

    Plugin Author Martin Schneider

    (@schneyra)

    Dude,

    we are not sure what you mean by “linked page”. Is it

    • The numbered link on the image that opens the lightbox?
    • A link on an image within the lightbox?

    – Martin

    Hi Guys,

    it’s really simple: (Frontend) click on the number in the calendar opens the lightbox with the defined image in the same tab/window in which also the calender sheet is. If i insert a individual link in the image options and check the checkbox “Open in new tab” (backend), a click on the image in the lightbox (frontend) opens the linked website in a NEW tab. All fine. But … the old window/tab with the lightbox is STILL their. So the user could be confused and/or i has to close it. These days thats one step to much for many users.

    But if i dont’t check the the checkbox “Open in new tab” (backend), the whole linked website will be displayed in the tiny lightbox, what is actually an iframe. That’s the problem.

    The better way would be: Checkbox “Open in new tab” is unchecked, so a click in the lighbox opens the individual link in the SAME TAB / WINDOW in which also the sheet is located. Not in the lightbox! 🙂

    I had a quick look at the documentation for GLightbox. And it says that you can output a picture instead of an iframe. I guess this is the problem. This could also be the solution to the problem of the scrollbars that appear when the image is larger than the iframe.

    Could you please have a look at it?

    Probably there are only a few code fragments that need to be exchanged.

    Plugin Author Dominik Schwind

    (@dominikschwind-1)

    I’m still not too sure where you find the “Open in new tab” checkbox, but I think I finally get what you’re trying to do. In your case you want your link to look like this: <a href="https://example.com/" target="_top">Click here</a>– the target="_top" opens the link in the uppermost container, which is your browser window.

    Okay, how hard can that be?
    Please, you know the option “Open link in a new tab” in the image details of each image in WordPress.

    See here: https://imgur.com/wpeMweO

    If the check mark is not set here, the website linked to the image opens in the iframe generated by the Glightbox.

    But that doesn’t make sense. It would make sense if in this case the Glightbox, like any normal Lightbox, only displays the image and clicking on the image opens the link in the same tab / browser window.

    Was that understandable now?

    AND … with the update on wp advent 1.3.3 the size of the iframe changed!

    Before I had to cut the images to the 877 x 481 pixel format so that they fit perfectly into the rigid iframe and no scrollbars were created.

    After the update it didn’t fit anymore. Now the size is 875 x 470 pixels.
    This is not funny, because I now have to cut 24 pictures again and I don’t have any time at all. ;(

    Do you test your plugin before you put the new version online?

    Plugin Author Dominik Schwind

    (@dominikschwind-1)

    Yes, we test the plugin and it works fine with our test themes. We try to build it with specific classes and ids to make sure it doesn’t collide with other CSS rules, but that is something we can’t always rule out. Luckily this is something that can be fixed with a couple of lines in your theme’s CSS.

    Furthermore, yes, I get it now what you want to happen with the links, I posted the solution – add target="_top" to your link. If you clicked that little box in your screenshot, the link should already have target="_blank" so you just need to replace blank with top – how hard can that be?

    Ok, thx for the hint. Replacing the target-Attribut “blank” with “top” solved the problem.

    I hope other users can learn from my problem and this solution.

    It would be very, very helpful if you could include this solution as an option in the plugin. This would make it a bit more user-friendly and improve your rating. You have to pay attention to so many things when using the plugin anyway. Every small step you can save with recurring operations by a clean configuration eliminates errors and saves a lot of time.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘New Page opens inside Glightbox / iframe’ is closed to new replies.