Support » Fixing WordPress » New Page and New Post Admin. Bug

  • Hello, recently all of the sudden when ever I am in the Dashboard and I click on either the “Add a new post” or “Add a new page” I encounter problems.

    The problems are the same in both areas. These two dashboard pages hang up during the loading process. They will sit there loading for more than 30 seconds and finally they finish loading. The other problem is that when ever I am trying to type in the text box, it keeps saving a draft about every 30 seconds and it freezes and stops me from typing twice every time it does this.

    Strange thing is that if I go to the edit a post on the Edit Post page it loads up quick with no problems after I have selected a post to edit. The same deal with editing a page, Edit Page after selecting a page loads up normal no problems. This does not make sense to me because these edit pages almost identical to the Add New pages.

    I did some searches on these forums and tried some fixes but they did not work. I turned off all of the admin plugins accept for the key ones like Akismet and Super Cache. This did not fix it so I did the other suggestion I saw on another thread and I reinstalled both the wp-admin folder and also the wp-includes folder. I used brand new fresh 2.84 folders off of a fresh download when I replaced them, and I did not reactivate the plugins before or after.

    When I go to my server’s error log it is catching what is doing. However, I am not a diagnostic computer code person. Therefore I do not know what these errors mean. Here is the error that shows up in the error log of my server.

    File does not exist: /home/metaman8/public_html/favicon.ico

    What else can I do to try to fix this.

Viewing 15 replies - 1 through 15 (of 26 total)
  • That error isn’t an indication of what’s causing your problem.

    Favicon

    Have you tried:

    – switching to the default theme to rule out any theme-related problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    So you are saying actually go in and clear out the plugins folder?

    Change, or add, the autosave interval in your wp-config.php.

    /** Change autosave default **/
    define(‘AUTOSAVE_INTERVAL’,600);

    That will solve your ‘saving a draft problem’.

    You might also try turning off post revisions, assuming you don’t need the feature. It might speed things up.

    /** Turn Off Revisions **/
    define(‘WP_POST_REVISIONS’, false);

    I haven’t looked at the feature in the new release but when it first came out it gave me all kinds of headaches. Plus, I kinda think it is, or was perhaps, horribly designed and should have used a separate table for the revisions. But I’ll not rant…

    The one error you spotted isn’t really a big deal. The browser is looking for the little icon that goes at the top left of the URL address bar. On this site it is the WordPress logo.

    Ok, so I went to the plugins folder and deleted all of the plugins that I had deactivated. It still does it.

    So now I have the wp-config.php file open.

    Where do I add in the

    /** Change autosave default **/
    define(‘AUTOSAVE_INTERVAL’,600);

    any particular spot in that file?

    Also I should mention that this started at about the same time that I enabled the feedburner subscription field that was built into my theme which is Pixeled. I can not be sure if it started before of after I did this. Could there be any kind of connection there?

    http://www.altimatrix.com

    It was not the feedburner, I just disabled and checked and it still does it. Therefore, I reenabled it.

    Just add that under the database information. You might want to type it out. Copying can sometimes result is strange characters.

    Ok, Good deal thank you apljdi. I will try that out.

    Also when I was looking at my error log before I was looking at the one on the control panel of the server. I just found the one that is inside of the File Directory and it says that this error happened today.

    [27-Aug-2009 16:34:44] PHP Warning: require(/home/metaman8/public_html/wp-includes/compat.php) [function.require]: failed to open stream: No such file or directory in /home/metaman8/public_html/wp-settings.php on line 246

    Ok, I just opened up the wp-settings.php file to have a look at it. Like I said I have no idea what I am looking at in that file because I am not a code reader person. However, should I replace the wp-settings.php with a fresh one from the 2.84 download? Or is there something else I should do about this/

    That’s a juicier error message. It suggests that you haven’t uploaded all of your WP files. You should probably try re-ftp-ing your core WP files to make sure they are all there.

    The ‘600’ in the AUTOSAVE_INTERVAL is time in seconds, by the way. Set it to however long you want.

    I tried adding in the

    ** Change autosave default **/
    define(‘AUTOSAVE_INTERVAL’,600);

    it still does it, it must have something to do with that error

    Like I said, try re-uploading your files.

    Posted by apljdi

    That’s a juicier error message. It suggests that you haven’t uploaded all of your WP files. You should probably try re-ftp-ing your core WP files to make sure they are all there.

    I would rather just replace the files that the error message is correlated to. Do you forsee any reason why the others would need replacing as well?

    The files have been uploaded and the wordpress installation has been working for quite some time without any problem. This glitch was out of the blue. I guess I could have been hacked and the file was modded, who knows?

    Well I just re-ftp’d the wp-settings.php and it still does it.

    aplijdi, when you say “core files” what files does this mean? All of them? I have already freshened up the wp-admin and wp-includes both before and after I deleted the plugins from my server.

    Still not working right, but the annoyance of the draft saving every 30 seconds is now gone. At least it has gotten to a level of usability at this point. Still would like to dial in the rest of it.

    ‘Core files’ are everything that comes in the wordpress zip file minus the wp-content directory. These are the files that everything else depends on. You need to re-upload everything. What you are missing is one of the files in the wp-includes directory. wp-settings includes that file (wp-includes/compat.php) on line 246 but it isn’t there, so you get an error.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘New Page and New Post Admin. Bug’ is closed to new replies.