Support » Networking WordPress » New Network, Domain Mapping OK but Dashboard not available

  • New to this and still confused.
    I had to experiment a lot for a few days before I appear to have got Domain Mapping working.

    My network set up is something like this:-

    (root)\(network domain)\
    (root)\(network domain)\(sub-site-1)
    (root)\(network domain)\(sub-site-2)

    (root) – this is the primary root domain and hosting space for my server.
    (network domain) – this is the folder holding this WordPress installation, now activated for multisite networking.
    (sub-site-N) – this is set up with folders for each additional domain I am attempting to use.

    Site Address (URL): (http: my domain) (no www. included)

    “my domain” is hosted on the same server and has been forwarded to:-
    (root)\(network domain)\(sub-site-1)

    Both root domain & forwarded domain have their own SSLs.

    Seen from outside “my domain” points correctly and shows the site: https://www.highocean.co.uk & http://www.highocean.co.uk

    HOWEVER, when I try “dashboard” off the admin control panel I get “not available” for “my domain/wp-admin” I have to switch the Site Address URL back to the ../(sub-site-1) address to access it.

    I haven’t understood something, but what?
    Any advice, clues, suggestions?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi @worldmaker

    Sorry for the trouble. It sounds like you have set up your WordPress multisite installation and domain mapping correctly but are having trouble accessing the dashboard for the mapped domain.

    There are a few things that could be causing this issue. Here are a few things you can try:

    1. Make sure that your SSL certificates are properly installed and configured for both the root domain and the mapped domain. If the SSL certificate for the mapped domain is not set up correctly, you may not be able to access the dashboard securely.

    2. Check your .htaccess file to ensure it is set up correctly for the mapped domain. The .htaccess file controls how your server handles requests for your site; if it is not set up correctly, you may not be able to access the dashboard.

    3. Check the WordPress settings for the mapped domain to ensure that the Site Address (URL) is set correctly. If the Site Address (URL) is not set correctly, WordPress may not be able to find the dashboard for the mapped domain.

    4. Ensure your server is configured correctly to handle requests for the mapped domain. If your server is not set up to handle requests for the mapped domain, you may not be able to access the dashboard.

    If you have tried all of these things and are still having trouble accessing the dashboard for the mapped domain, there may be an issue with your server or hosting provider. In this case, contacting your hosting provider for further assistance may be helpful.

    Thread Starter worldmaker

    (@worldmaker)

    @faisalahammad

    Thank you for your prompt advice.

    I’ve tried a clean .htaccess file, with nothing but wordpress code, and no change there.

    As far as I can tell all the SSLs are routing correctly, all on the same server for both the parent location and the mapped domains and all part of one SSL package for all my sites.

    As you know the mapping works for visiting the site but not for the Dashboard, so that makes me believe it is internal to WordPress itself. Perhaps because I have the site rooted out of a folder under the parent domain this is not working.

    As for my service provider. They appear to be WordPress-friendly and there doesn’t appear to be any problem with me managing several sites off the one service package.

    I wish I could do more but I’ve no time or skill. Perhaps I will try to raise this as a technical challenge for the developers to look at.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.