Support » Plugin: Backup and Staging by WP Time Capsule » New method to include/exclude files is not working

  • Resolved Marcelo Pedra

    (@kent-brockman)


    Hello guys, I were to select new files to include/exclude and found the method is not working. I click on include/exclude links and nothing happens.
    I tried emptying cookies and browser cache. Even switching PHP versions between 5.6 and 7.0 doesn’t seem to effect. It simply don’t work here.

    It’s a bug in you javascripting:
    https://drive.google.com/file/d/0B4ZIdz9VEIQGQ2MtQ1BpaVdVY3M/view?usp=drivesdk

    My only concern is that this bug don’t screw the previous restore points in subsequential backups until you fix it.

    Thanks in advance
    Marcelo

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same here.
    I received your email yesterday about this version that sated this:

    If you’ve included a non-WP file/folder or excluded a WP file/folder, kindly go to your settings and include/exclude your files again. Since we’ve done a complete overhaul to the plugin, we couldn’t retain your old settings. My sincere apologies for the inconvenience caused.

    Unfortunately this doesn’t work anymore.
    Files/folders that were previously excluded can’t be switched to be included and those that were previously included can’t be excluded.

    Plugin Author WPTimeCapsule

    (@wptimecapsule)

    Hey Marcelo/John,

    We’ve fixed the functionality of the Include/Exclude button with v1.8.6. The update has just been released about 10 minutes ago. Updating to the latest version should fix this for you 🙂

    Regards,
    Tauseef

    The same thing happens to me, even with version 1.8.6.

    Plugin Author WPTimeCapsule

    (@wptimecapsule)

    Can you clear your browser cache and try again?

    Tested with a couple of sites on different servers and version 186 works for me.
    But I noticed that one have to click on word include/exclude at right side – and not on the folder/filename itself.

    Besides that, it’s a pity that partial selections do not show up at main folder’s name and we have to expand all folders to see what happens inside. Some other plugins that deal with folder/file selections use to grey a given folder when files inside are only partially selected.

    PS: getting those errors since update:

    PHP Notice: Undefined index: backup_before_update_setting in /wp-content/plugins/wp-time-capsule/wp-time-capsule.php on line 2908
    
    PHP Notice: Undefined index: user_excluded_tables in /wp-content/plugins/wp-time-capsule/wp-time-capsule.php on line 2913
    
    PHP Notice: Undefined index: user_excluded_files_and_folders in /wp-content/plugins/wp-time-capsule/wp-time-capsule.php on line 2916
    • This reply was modified 3 years, 10 months ago by John.
    Thread Starter Marcelo Pedra

    (@kent-brockman)

    @wptimecapsule now it works well.

    But as @dsl225 pointed out, the greyed box marking if it had full/partial selection used to be a good visual aid. Although, you usually want everything to be backed up, except for the typical cache folder.

    What I don’t understand is, is why WPTC plugin folder is deselected by default.

    BTW, I’m not seeing PHP errors logged. At least, not under PHP 7.0.

    PS: the errors above are with PHP 5.6

    Plugin Author WPTimeCapsule

    (@wptimecapsule)

    Hey John,

    Thanks for letting us know. We will fix it in the next release. It is happening when you click “Save Changes”

    Sorry for the UI change – it was consuming a decent amount of memory to fetch that data. We will be constantly improving the experience.

    I still have the same problems with the interface includes / exclude
    I’ve cleared the browser cache. I have tested with Safari, Chrome, and Firefox. I use MacOS 10.12.4.

    Plugin Author WPTimeCapsule

    (@wptimecapsule)

    @fergofer00 – Can you kindly mail us at help at wptimecapsule dot com? We will be glad to look into it for you.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘New method to include/exclude files is not working’ is closed to new replies.