Support » Plugin: Flamingo » New Messages marked as spam

  • Hi,

    I need some help. I have CF7 with Flamingo (both the latest update) but a lot of forms I received are marked as spam. But they’re not spam! How can I fix this problem? How Flamingo spam filtering works?

    Another question.. Is ther a way to send again the email when I change the status of the messages from “spam” to “not spam”. The most important thing form me is to collect the emails.

    Thank you!

Viewing 15 replies - 16 through 30 (of 32 total)
  • @wtheel @nikkofir @gjhead @graficavillcom

    Still had this problem up until today, in fact it got worse, marking pretty much marking everything as spam and not letting the second submission go through to flamingo inbox.

    Anyway I found a solution that worked for me, for now! Here’s the steps that I took, I’ve noted them all down here to try and eliminate for you:

    1. Removed recaptcha keys – no change
    2. Disabled Flamingo – no change
    3. Disabled several other plugins I had to do with spam – Askimet and CF7 honeypot – no change

    What did work was rolling back the CF7 plugin to Version 5.1 using https://wordpress.org/plugins/wp-rollback/

    and then redid the Recaptcha making new keys – still using V3.

    For me the issue definitely seems to be with the latest CF7 update 5.1.1 @takayukister

    Don’t particularly like rolling plugins back, but for a live site where CF7 is used as a main functionality there was no other option for me, the contact forms need to work.

    Everything right now seems to be working as should, will keep you updated if anything changes. Hope this helps!

    throotsdev

    (@throotsdev)

    confirmed here. are you using safari?
    since 5.1.1 you get an error in safari when using cf7 and recaptcha v3:

    “The source list for Content Security Policy directive ‘script-src’ contains an invalid source: ”strict-dynamic”. It will be ignored”

    i think: it’s a safari or recaptcha script integration error/bug. even on the google recaptcha demo page, the error is present (without cf7 of course). see the dev tools console on the following google recaptcha demo page:
    https://www.google.com/recaptcha/api2/demo

    @takayukister is there any update planned? maybe anything you can do when inserting the recaptcha script, so, that safari doesn’t throw an error?

    throotsdev

    (@throotsdev)

    one more thing:
    the error on the racaptcha demo page https://www.google.com/recaptcha/api2/demo is present, but the form is not seen as spam and gets submitted.

    @takayukister is there a way to check cf7 and find out, why it marks cf7 forms sent in safari as spam but not on the google demo page.

    Hello,
    I’ve got the same problem.
    Did anyone solve the bug?

    I am also looking for a solution.
    @takayukister Please take a closer look.

    nikkofir

    (@nikkofir)

    Bumping this – this is a major issue for our site.

    Messages that are incorrectly marked as spam are NEVER delivered – even if they are manually marked as “Not spam”. No spam filter is perfect – we need to be able to correct the occasional failure…

    Additionally, the option to adjust the recaptcha threshold from the current hard-coded 0.5 value would be of help.

    Bumping this also @takayukister Please take a closer look.

    I manage multiple business sites and spend each morning filtering through Flamingo. I then have to snip pictures of each message that did not make it through and send it to the intended parties. I have been asked if the message would forward to them and this would be great when I mark it not spam that it would. Otherwise this could be money lost and unhappy customers.

    I can also see where many have made 2-3 attempts before getting a successful message through which fills up Flamingo along with the spam messages.

    Bumping this because it is an issue for a lot of sites and the developer is choosing to ignore it!

    I only noticed this issue just now on a client site. Will have to check all other sites now and hope that this has not caused too much trouble so far.
    I don’t understand why a form plugin (or any other plugin) would do anything to mark and dispose of spam without the user having any control over it. It shouldn’t.

    bump, I also struggling with this bug, hope it gets solved soon

    Same situation as above, customers receive errors on submission, CF7 flags as spam, and mail never gets delivered.
    Why doesn’t dev respond?
    Its a great plugin and I would pay$
    We are hosting on AWS.
    Is it time to drop CF7 ?
    My customer is flaming mad at the email situation 🙁

    Going to use a different solution on this site.

    • This reply was modified 4 months, 2 weeks ago by cpt.randall.

    I was having the same issue in CF7 5.1.3. A lot of messages ending up in the spam folder of Flamingo and every form reported “There was an error sending your message. Try again later” when trying to submit anything.

    What solved it for me was disabling two optimization plugins: one that asyncs the load of every javascript file and another that minifies and concatenates CSS, JS and HTML.

    I had to disable both to make CF7 functional again. They are Async and Autoptimize. The dev dodged the ball blaming it all on these plugins but by this thread I suspect is more an error in CF7 code that interferes with these types of optimization plugins.

    Could you guys try to disable your optimization plugins (for those of you using similar plugins) and see if you can replicate my situation? Maybe this could help the author to debug this problem.

    I do not have any optimization plugins or anything similar installed. I have this issue independent of any other plugins — the problem persists when there are no other plugins enabled.

    Also: this issue should not have been marked as resolved.

    • This reply was modified 4 months, 1 week ago by WTHeel.

    I agree with WTHeel (@wtheel). Not all of my sites had optimization plugins and these sites still had issues. I monitor these sites daily to forward any emails that were caught by spam.

    This should not have been marked as resolved. It has not been resolved. You should have asked the rest of us to test first before marking it such.

    Hi to all of you,

    I agree with @cyaburt and @wtheel: this issue should not have been marked as resolved because it’s not and the author @takayukister is not answering to all of us.

    So I started this post and now I changed the status to “not resolved” again as it should be (I really don’t know who changed the status) and hoping that the author will respond.

    Thanks to all of you

Viewing 15 replies - 16 through 30 (of 32 total)
  • You must be logged in to reply to this topic.