Support » Plugin: Flamingo » New Messages marked as spam

  • Hi,

    I need some help. I have CF7 with Flamingo (both the latest update) but a lot of forms I received are marked as spam. But they’re not spam! How can I fix this problem? How Flamingo spam filtering works?

    Another question.. Is ther a way to send again the email when I change the status of the messages from “spam” to “not spam”. The most important thing form me is to collect the emails.

    Thank you!

Viewing 15 replies - 1 through 15 (of 34 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Flamingo doesn’t do spam filtering. Contact Form 7 does.

    Ok, thanks for the clarification.

    So do you think it’s only a recaptcha issue? Do you know if someone else had the same problem and how to fix it?

    Besides as I wrote before I think it would be very useful if Flamingo could resend email when I marked a message as not spam. Do you think it will be possible in the future?

    Thank you very much.

    Any updates?

    Even if I delete recaptcha from my contact forms, 70% of all messages continue to be maked as spam… and they’re not! The only way I can see them is from Flamingo.

    What is doing spam filtering in Contact Form 7?

    I’d appreciate any possible help.

    Thank you!

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Hi @takayukister,

    Thank you, but that’s not my situation.

    On my form I have not spam-filtering (Recaptcha, Akismet, etc.) and I don’t want them. It’s exactly the opposite problem: messages go into spam but it’s wrong because they’re not spam. So I can’t understand which is the reason of this problem.

    Similar issue here with latest WP and plugin versions as of today. reCAPTCHA v3 enabled for CF7.

    After deactivating Flamingo plugin messages stopped being flagged as spam. I’m going to leave it disabled for now.

    Similar issue here as well – loads of form fills in spam folder of Flamingo even though they are just regular form fills. Waiting for a solution for this.

    Has anyone found a solution? Also facing the exact same issue to the point where users are not able to submit my form without getting an error message.

    Granted I am still getting spam that the filter is capturing, so I don’t want to have to disable Flamingo…

    Hoping someone has identified the issue and a fix?

    Thanks!

    Same issue as well, New messages are getting marked as spam, but I think some on the second submit seem to be getting through to inbox folder. As I have duplicates in both the spam and inbox folder on flamingo.

    This wasn’t hapening before I updated the site and plugins, so I’m not sure where the issue is from, CF7, flamingo, askimet, new wordpress update possibly?

    Anybody got any solutions? I’m going to try to rollback some versions of the plugins one by one and report back.

    I’m in the same situation. Starting 8 days ago, we stopped receiving email through CF7. All email since then is in the spam folder in Flamingo.

    I deactivated Flamingo and it did not help (the test email never made it to me), which makes sense since @takayukister says Flamingo does not filter spam.

    If I am understanding correctly, CF7 checks whether a form submission is spam. If the submission is spam, Flamingo labels it spam and I can see the submission under “spam” under “inbound message.” If the submission is not spam, CF7 sends the email and Flamingo files the email under “inbox.”

    @sophierose did you ever find a solution?

    The issue appears to be an issue with CF7. I removed the recaptcha from the form and it did not help. I also tried CF7 with all forms deactivated and the default WordPress theme. My host is not seeing any mail errors because the email is never attempted once CF7 determines that the submission is spam.

    • This reply was modified 1 year, 9 months ago by WTHeel.

    Had similar thing happening, but when I removed the reCaptcha keys from contact form 7 under the “Integration” tab it stopped everything being marked as spam. I still have reCaptcha on the site using Invisible reCaptcha plugin. It was only through the contact form 7 integration that it was causing everything to be marked as spam.

    Hi @ermaecthiaael,

    Thank you. But I’m not using reCaptcha keys. Spam is always here!

    Did anybody found a solution?

    Same issue – also wondering if there is a way I can manually export all the spam entries. The “Export” option disappears on the “Spam” listing.

    Also, terribly baffled as to how it marks something as spam in the first place.

    Can’t find any documentation on how a message is put into the spam folder e.g.

    • if Akismet is not installed, yet we still see messages in the spam folder, is it using reCaptcha for this?
    • If reCaptcha and Akismet are not enabled, how is it possible for CF7/Flamingo to decide if a message is spam?,
    • If a message is marked as spam, is it still sent to the form recipient (I’ve seen messages that are in the spam folder AND in the inbox),
    • What happens when a message is marked as ‘not spam’ – will it then be delivered to the recipient?

    This page that the plugin author has twice pointed us to: https://contactform7.com/faq/i-get-spam-messages-through-my-contact-forms-how-can-i-stop-them/ is not helpful, it does not answer any of the questions above.
    The author has also stated that Flamingo does not do spam filtering, CF7 does – but without Flamingo installed, there is no ‘spam’ inbox for us to view, so this does not make any sense. Does CF7 without flamingo simply ‘disappear’ a message if it decides (somehow) that it is spam? CF7 states specifically that it does not store messages.

    I am concerned that messages are now being missed via an undocumented spam filtering process. Please @takayukister can you respond to this thread?

    Found this answer on another thread:
    https://wordpress.org/support/topic/regular-mails-are-in-my-spam-folder/#post-10762797

    @takayukister states that

    If a submitter fails the reCAPTCHA test or leaves it blank, the spam flag is set and Flamingo will put the submission to the Spam folder. That is a normal intended behavior.

    So this appears to be an issue with Google’s reCaptcha – however, we still need to know how to ‘re-send’ a spam message that is then marked as ‘not spam’…

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘New Messages marked as spam’ is closed to new replies.