Support » Fixing WordPress » New menu item not appearing

  • When I add a new menu item from dashboard, it shows on the list but not on the site. When I add a new menu item from site edit, it shows on site but not on the menu examined from dashboard. Something seems fundamentally wrong here.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Looks like you posted this in your theme’s support forum earlier (where this belongs!), and you’ve been answered there already.

    https://wordpress.org/support/topic/new-menu-item-not-appearing/

    Good luck!

    Hi @jcoonrod did you set the menu location in menu dashboard? Please check it in your menu dashboard. And then check the place where the menu is selected, is there also location selected?

    what theme are you using. If it an FSE theme it has to be set from the new site editor. Your menu options should have been disabled. FSE disables widget,menu,and the customizer.
    Some plugins like woocommerce will reenable the customizer. These items are being phased out. Shortcode can still be used in FSE but it difficult to get widgets to work under FSE themes. Not sure why you would even have the option to use the old menu options.

    Not sure why you would even have the option to use the old menu options.

    Tested, and it’s the Blockbase theme OP is using that’s exposing the “Classic Menu” UI. I also found it’s possible to select the named menu under “Classic Menu” in the block editor, but it looks like OP didn’t choose this option. Explained with screenshots in the linked theme post above.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.