Support » Installing WordPress » New Install Won’t Create Tables

  • Rand Simberg

    (@rand-simberg)


    I’m trying to do a new install in a new domain. I created the database using MySQL, and configured wp-config. When I try to do the install, I get a huge page of errors like this:

    WordPress database error: [Table ‘simberg_intraorbital1.wp_users’ doesn’t exist]
    CREATE TABLE wp_users ( ID bigint(20) unsigned NOT NULL auto_increment, user_login varchar(60) NOT NULL default ”, user_pass varchar(255) NOT NULL default ”, user_nicename varchar(50) NOT NULL default ”, user_email varchar(100) NOT NULL default ”, user_url varchar(100) NOT NULL default ”, user_registered datetime NOT NULL default ‘0000-00-00 00:00:00’, user_activation_key varchar(255) NOT NULL default ”, user_status int(11) NOT NULL default ‘0’, display_name varchar(250) NOT NULL default ”, PRIMARY KEY (ID), KEY user_login_key (user_login), KEY user_nicename (user_nicename), KEY user_email (user_email) ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ci

    It does this for every table. When I go in and look at the database in PHPMyAdmin, I see the schema, but no tables. In theory, I could build them manually, but life is too short.

    I’ve done many installations/upgrades, and never encountered this problem before. I’ve tried creating new databases, creating new users, and always get the same result. What am I doing wrong (if anything)?

Viewing 16 replies (of 16 total)
Viewing 16 replies (of 16 total)
  • You must be logged in to reply to this topic.