WordPress.org

Support

Support » Multisite » [Resolved] New install, went fine, but can't get themes to enable?

[Resolved] New install, went fine, but can't get themes to enable?

  • I enabled multisite use (yay!) and it seemed to go fine, but the very first thing I’m doing after creating two new users/sites is to upload new themes.

    I’m clicking to enable them, but I don’t see the default theme changing, in either site.

    ?

    I have a feeling I’m going to be here a lot, so thanks in advance for helping!

    (BTW, I’m not a programmer, so the more simplistic the instructions, the better. 😉 )

Viewing 15 replies - 1 through 15 (of 24 total)
  • You enable themes in the Network Admin and then you need to visit each site and activate the theme, just like you do in single installs.

    Voila! Thanks so much. Network first, then site. 🙂

    And if you wanted the theme enabled for one blog and none of the rest to have access, this
    http://wpmututorials.com/themes/enabling-a-theme-for-just-one-blog/

    (slightly outdated, process the same)

    Thanks, Andrea. I was actually just searching for how to change the default theme but found it.

    (I feel like I know you already, because I’ve been Googling like a mad woman all day, researching WPMU/multisite, and kept stumbling upon your informative posts. Thanks. 🙂 )

    Well, until I decide on a default theme, I’m trying to select the same network enabled theme for one of the sites. A message says “Network enabled themes are not shown on this screen.”

    I can’t figure out how to enable a site with the same theme the network is using.

    ?

    I still can’t enable themes on the sites (it worked for the Network site). I saw this forum discussion about the same:

    http://wordpress.org/support/topic/how-to-select-a-theme-for-multisites-different-from-main-site?replies=19

    Has anything changed since that time as far as the code to be inserted in .htacess? Here is what I used, per my host, Hostgator:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]

    Is there something missing or in error which is preventing customizing the sites?

    Thanks much. 🙂

    UPDATE: (I case others stumble across this and have similar trouble)

    I replaced the above code provided by host with the following, and I was able to get the one enabled theme on a site to take effect. 🙂

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Okay, your response showing what works tells me you were asking a different question. 😉

    You were asking how to *enable* a theme, which is different than the selected activated theme not being applied to the sub blog.

    Completely different questions with two very different answers. 😉 Just so you know why.

    Yes, Andrea. 🙂

    I fear my ignorance about proper terminology will lead to confusion, so I’ll do my level best to be as clear as possible in the future

    Thanks again. 🙂

    (not a lecture, I promise. 🙂 )

    😉

    Wow, I am so lost it isn’t even funny. 🙁 I may have to abandon this multisite approach for now.

    But in trying to figure things out, and Googling to get help in doing so, I found a tutorial that mentioned I should have a menu for SuperAdmin.

    I don’t have that.

    I went through the steps to install WP 3.0 and activate multisite, and see “Network” settings and setup, but I do not have a SuperAdmin anything.

    Is that possibly something that could make things less confusing? Am I missing something obvious since that isn’t part of my dashboard? If so, how can I get this?

    My user name does NOT have an uppercase letter.

    No you don’t have a menu for super admin anymore.

    You have a LINK on the upper right of your screen.

    Read http://codex.wordpress.org/Create_A_Network – See the bit in yellow? That’s what happened 🙂

    Darn, I was hoping there was something else I neglected to do that would help me have an “aha” moment. Back to the drawing board — and tutorials — of wrapping my brain around this whole setup.

    Thanks. 🙂

    So … you don’t have that link either?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] New install, went fine, but can't get themes to enable?’ is closed to new replies.