Support » Plugin: Sublanguage » new install not working

  • Hi,
    I have a pretty new installation and for whatever reason I cannot get sublanguage to work on it. Using Metro Magazine theme.

    Deactivated plugins one by one, could not find the culprit.

    What happens is that I cannot get the language tabs on post/page/category edit screen (or listing) to switch between the 2 languages, and also the previously existing text in the main language is not there anymore (I mean I cannot see it but if I disable sublanguage the old text in the main language is back there).

    Any idea why this happens and how could I fix it?

    Using PHP 7.2

    Thanks a lot

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello, did you check with debug mode on (define('WP_DEBUG', true); in wp-config.php)? Is there any warning showing?

    Hi Maxine,
    I had to switch to smth else on that site, there was no way to get it working with sublanguage, no idea why

    Thanks!

    Hi,
    having the exact same problem, cannot switch between languages on post.php.
    When clicking the tab, the language parameter is added to the url and the post is updated, but no way to enter content for the non-default language. No warnings in debug mode either.

    This is on a fresh install (4.9.8), using Twenty Seventeen theme and no other plugins. Plugin version 2.5 with default settings.

    Any idea how to fix it? Would love to use this plugin, seems like the perfect qTranslate alternative.

    Hello,
    Maybe it is just a front-end browser problem… Can you give me your web browser name, version, and operating system? If possible, can you try with another browser just to check if this is the issue?

    Hi,
    thanks for your quick reply!
    You are correct, as it turns out I am only experiencing this problem in Chrome (latest version 70.0.3538.110) on macOS.
    It works fine in Firefox and Safari (also on MacOS).

    Sorry I could not reproduce this bug, but I made some changes in the language switch code… Would you try to see if it is fixed? You can download the developping version here: https://downloads.wordpress.org/plugin/sublanguage.zip

    Hi,
    still no luck I am afraid. I have installed the dev version, but the bug is still there in Chrome on macOS. No problems in Firefox or Safari.

    As far as I am concerned I am happy to log in with another browser so I can use this plugin in my site.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘new install not working’ is closed to new replies.