Support » Installing WordPress » New Install IIS 5 Can't Login reauth loop

Viewing 15 replies - 1 through 15 (of 20 total)
  • CANNOT LOG IN ANY MORE AFTER INSTALLING LATEST VERSION OF WP

    I have a similar problem. After updating to the latest version of WP, I cannot log in. Moreover, the whole website is inaccessible on the internat- the usual 404 error message.

    /tmdoctors

    How’s it going tmdoctors? With my limited experience I’m not sure I can help much. Your problem sounds more like a permissions issue though. I created a virtual directory with the Internet Services Manager to point to my wordpress directory and I think that took care of the basic permissions.

    Anybody think they know where the quirks are in WordPress 3.2.1 and IIS5?

    I got the advice to start with reinstalling 3.2.1 (after backing upp the WordPress directory) before doing anything else. As I installed it upon 3.0.5 I was warned for installing an older version, because with 3.2 important changes were made (see http://wordpress.org/support/topic/to-wp-team-321-buggy-please-make-the-former-version-available?replies=10#post-2345606).

    So my first attempt will be to reinstall 3.2.1 when I have time. The reason to do it is that I was told that this version has been installed by hundreds of thousands of users without problems so it is is more likely that there was a defect in the installation package. If this is the case, the bug is perhaps in the packaging program of WP so that it sometimes generates damaged files.

    mlustig- Are you using a rewrite module for IIS 5? Do you have any rewrite rules defined in your web.config file?

    From your post I take it you have never logged in to set the permalinks. I am guessing that this is a rewrite issue as that was an issue on IIS 5 and IIS 6.

    kcristiano – that sounds very helpful, but I have no idea what a rewrite rule is and how one would define them. Can you help me with that. You are correct that I have never logged in or set permalinks. May I assume that you mean so permalinks are therefore not the problem?

    I did find some very old discussion from WordPress 1.5 days with specific fixes for the “IIS 5 problems” here . But the current php files are so different now that I couldn’t implement them.

    Anyway I’m really excited that you might be able to help me get this solved. Thanks.

    I was asking about permalinks to see if you had set them to anything that could cause an error.

    As far as the redirect, you will need to know how your webserver is setup (or have someone you can talk to that knows). IIS 5 is very old and even Microsoft does not support it any more.

    The link in your post talks about modifying core files. That is bad. Don’t modify core files. A core file is anything that is not a plugin or theme you have uploaded.

    The only file you should be editing is wp-config.php

    If you have access to the files in the wordpress directory, can you tell me if there is a file called we.config?

    I have access to all the files on server. Nobody helps me with the IIS setup. There are people who should help me, but they always have more important things to do. That’s why I’m stuck doing this. As for modifying core files, I promise to stop now that you’ve warned me. Especially if the site will start working, because then I’ll have better things to do.

    I looked in the wordpress directory and in the three main subdirectories, and I don’t see any file called we.config. Unless it’s hidden deeper somewhere, it’s not there.

    Sorry, bad typing. I meant to write web.config, but after thinking back I am not 100% certain that IIS 5 used a web.config file. Anyway, check and see if it is there.

    What happens if you go to the front end of the site, http://mysite.mydomain.com does that show anything?

    Are there any other web sites on this server?

    If the site is working at all, can you share a link.

    I thought maybe that was a typo.

    Yes, I can see the default web page. There is only one web site on the server and the wordpress site is configured as a virtual server on the site, so it’s http://mysite.mydomain.com/WordPress

    I would love to share a link, but the server is behind a firewall and I can’t get you through it.

    Meanwhile, due to your clue, I have found something called WordPressURLRewrite and while you are typing I’m giving that a try.

    Is there another site at http://mysite.mydomain.com?

    Truthfully, if you are forced to use Windows Server 2000, and no other sits are using IIS 5, I’d consider switching to Apache for Winows.

    Installing a urlrewrite module may further complicate matters, especially if there is one there already. Something is causing the redirect, most probably a setting inside IIS.

    Oh. I’m not sure I understand what you are getting at. You are saying that the problem is that something is causing a redirect on my site, not that I need to install a redirect on my site? (Cause I did that while we are chatting and it ain’t working).

    There is an existing site at http://mysite.mydomain.com, in the root, and in a variety of subdirectories.

    The biggest reason is I feel stuck with this IIS configuration is that we have been using Microsoft FrontPage for all of these years, and have some ASP applications set up that rely on FrontPage that would be a pain to try to migrate.

    Do you think FrontPage could be causing a conflict?

    Without knowing all the configuration details, its impossible to say with certainty.

    However, if you have a site in the root directory, the WordPress site will (by default) be subject to all its settings (at least on IIS 5). Front page is not helping, that is for sure.

    WordPress on IIS before version 7 is difficult. Complicating this with having it reside in a subdirectory where it will inherit settings makes it extremely difficult. Changing this requires specific knowledge of how to configure IIS 5 to allow subdirectories to have their own settings. I would never attempt an install in this configuration without an expert in IIS 5 available to help.

    You’ve given me a lot to think about. Perhaps I can set up a new web site on my Windows machine, without the FrontPage Extensions. Or maybe I can just move the wordpress folder out of the web root but still access it as a virtual directory. I will try that tomorrow and let you know if I have any success. Thanks for all your help.

    Update:

    I installed a new IIS site on my server at a different port. Did not install FrontPage extensions. Dropped all the tables from the database. Moved all the files and Installed WordPress to the new site. Same problem.

    So I guess it wasn’t FrontPage?

    Also, I did find the web.config file on my server. Should I be doing something with that?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘New Install IIS 5 Can't Login reauth loop’ is closed to new replies.