Support » Plugin: Jetpack by WordPress.com » new install gives HTTP 404

  • Resolved ghp123

    (@ghp123)


    Hi Jetpack,

    I run a bunch of wordpress sites on one hosting plan and i installed jetpack on all of them but 2 give me an error

    “Error Details: The Jetpack server was unable to communicate with your site [HTTP 404]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.com/support/”

    I don’t think it is my hoster as all sites run on the same hosting plan and 8 went fine only 2 give this message.

    Any idea where i need to look to fix this?

    greetings,
    George

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Hi Jeremy,

    The sites that didn’t work are thlog.com and shopdoctorwho.com and as an example of a site on the same server that did work ghptravel.com

    Thanks,
    George

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    We seem to receive a 404 error whenever we try to communicate with both sites from a WordPress.com server. Do you use a security plugin that may restrict access to your site? If so, could you try to deactivate it for a few minutes, and let me know if it helps?

    I use bruteprotect can capatcha on my sites and some use cloudflare.

    i turned all 3 off for now at shopdoctorwho.com but that does not solve my issue but maybe you can reach that one now?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I’m afraid I still get the 404 error when trying to communicate with your site from a WordPress.com server.

    I’m afraid I don’t have any more specific information: the 404 page I get is a generic one.

    Could you check your site’s .htaccess file, to make sure that no rules restrict access to xmlrpc.php there?

    P.S.: it’s worth noting that you don’t need to install the BruteProtect plugin anymore; its features were merged into the Jetpack plugin a couple of years ago.

    The only thing in the .htaccess for shopdoctorwho is

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    So that does not look like the problem either.

    And sure BruteProtect maybe in jetpack but if i can’t get it to work then i am stuck with the plugin 😉

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Can you please use Jetpack’s Debugger module to send us some more information about your site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says “click here to contact Jetpack support.”
    4) Fill in the description box and your name and email address.
    5) Click the “Contact Support” button to send us the debug results privately. It’s best not to post this information on public forums, as it contains private details about your site.

    Thanks!

    Thanks Jeremy,

    I just send the debug report but when I pressed submit it brought me to the https://jetpack.com/contact-support/ page so I wonder if it worked?

    OK never mind just got a confirmation email 🙂

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That should be okay, yes. We’ll get back to you soon!

    Thanks for all the help Jeremy and it ended up being cloudflare but the solution can be found at

    http://www.dianastarts.com/is-cloudflare-blocking-your-jetpack-plugin-install/

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That’s interesting, thanks for sharing! My own site runs CloudFlare and Jetpack and I didn’t experience any issues, but I suppose this could depend on your CloudFlare settings.

    I’m glad to hear you could figure things out!

    It surprised me too as i run more site on cloudflare all with the same settings but only these two game me problems.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘new install gives HTTP 404’ is closed to new replies.