Support » Plugin: WP Data Access » new install. Error Message: Cannot read properties of null

  • Resolved sirbdc969

    (@sirbdc969)


    New install for testing.
    Created table “tst_books”
    single column “id” int, auto_increment
    Saved design, created table.
    Went to table explorer, clicked on “Manage” link.
    Boom.

    Dropped table. Created new with single nvarchar test field. save/Create. Table Explorer> Table > Manage. Boom.

    Error: `Error Message: Cannot read properties of null (reading ‘href’)

    TypeError: Cannot read properties of null (reading ‘href’)
    at :1:1373
    at Array.forEach ()
    at :1:1299
    at t (:1:1748)
    at :1:149299
    at $r (:9:83333)
    at unstable_runWithPriority (:9:7431)
    at xn (:9:29950)
    at Qr (:9:82796)
    at :9:82707`

    Tried hitting a WP table in table explorer to see if it was just WPDA tables, same error.

    Seems to be trying to load the entire WP site into a child frame, but that could be a result and not a cause.

    Vanilla WP theme Baskerville-2 (not a platformer). Vanilla Child Theme just to remove the WP from the footer. No other 3rd party plugins, just thinned number of host plug-ins (Jetpack, Yoast, Google Analytics by Monster)

    Must be something really obvious. Any suggestions?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter sirbdc969

    (@sirbdc969)

    fyi: used SQL editor to insert records in tables, the Tale Explorer shows the count of records in the table so INSERT INTO is working. BUT that is all I can do with SQL explorer, doing a SELECT COUNT(*) or SELECT([column name]) returns nothing visible, the Executing spinner spins then stops… no error or results grid that I can see. Maybe not seeing a results display in the SQL editor is related? (Maybe not).

    Thread Starter sirbdc969

    (@sirbdc969)

    Deactivated all plugins (Jetpack, Yoast and Google Analytics were all there was in this brand new WP staging site). Flipped on wp debug log. Still SQL Editor does not show any results for any SELECTS (tables viewed in phpmyadmin show the records from INSERTS in the tables). the Table Explorer > Table > Manage link crashes with above error.

    No errors in debug.log.
    Weird.

    Is everyone else having no problems with the current, updated just days ago, installation code?

    Is there a previous version available to use as a test?

    Plugin Author Passionate Programmer Peter

    (@peterschulznl)

    Hi @sirbdc969,

    When you open the inspector:
    – Are there any errors on the console?
    – What is the response you get from your admin-ajax.php requests?

    Thanks,
    Peter

    Thread Starter sirbdc969

    (@sirbdc969)

    Thank you Peter, I sincerely appreciate your reply. The error that the wordpress admin raises are in the original post. I see no debug.log entries. admin-ajax.php is a new one to me, forgive my ignorance, so I will have to lookup information on doing that.

    Your system is truly wonderful in scope. I see that many, many, many people are using it to do Actual Database work beyond just forms and so I know that this can be figured out.

    Thread Starter sirbdc969

    (@sirbdc969)

    host (Bluehost) redirected debug, found error.log. no entries related to this OR any new test crashes – lots for another “not-really-a-db” product’s testing last week ;). no admin-ajax.php entries at all. Maybe host blocking a port? No port settings seen in WPDA settings.

    SQL editor doesn’t even return for a SELECT ‘this is text’ AS ”; test. No errors, no crash, just the Executing spinner spinning then nothing.

    Thread Starter sirbdc969

    (@sirbdc969)

    Dagnabbit. Tracked it down. The one plug-in that I never removed from the test site was the Hosts’ own branded plugin. I hesitated because, you know, they are my host and they have been absolutely great compated to others I have tested. I figured that theirs was really important to keep above all else in any deployment. Deactivated it and viola… Manage works and SQL Editor returns values.

    I am so very happy because after testing a number of “Database” products and all of them having one limitation or another with my spec yours, with actual Database connectivity, looked like a winner. And with this complete noob silliness on my part figured out, I can move on to testing that actual spec.

    Thanks so much Peter.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.