Support » Plugin: LiteSpeed Cache » New images uploaded not optimized.

  • Resolved Shah Ahmad Yusof

    (@shahahmadyusof)


    I was originally hosted at SiteGround. But then moved to DigitalOcean due to various reasons. Before moving, everything is working perfectly. But after everything still working great except I cannot optimize new my images. If I upload new images, any of below or all of below or some of below will happen:

    1. New images optimized but only optimized 1% ~ 2% from their original.
    2. New images optimized perfectly (Optimized 30% – 90%) but no webp version.
    3. New images optimized perfectly (Optimized 30% – 90%) with webp version but no original images which means I cannot revert to original in any worst case.
    4. Webp version not generated at all.
    5. No original files available if optimization successful.
    6. Images not optimized at all (both using manual and Auto Request/Pull cron).

    What I have tried to fix:
    1. Disable all plugins/themes except the LiteSpeed plugin.
    2. Disable my server firewall.
    3. Clear all cache from all devices (Server, phone, computer).
    4. Clear all cache from Cloudflare and/or using development mode.
    5. Disable CloudFlare by removing my site entirely from Cloudflare.
    6. Revert to LiteSpeed 3.5.0.2 and 3.5.1. (Currently using the latest version of 3.5.2)
    7. Disable my server swap files (1GB).
    8. Rebooting server.
    9. Rebooting LSWS.
    10. Rebooting my devices (computer/phone/router).
    11. Refresh domain key on LiteSpeed plugin.
    12. Detached all connected nodes from the LiteSpeed plugin.
    13. Clear all cache from the LiteSpeed plugin including “Empty Entire Cache”.
    14. Do “Clean up unfinished data”.
    15. Do “Destroy All Optimization Data”.

    Additional Info:
    1. I’m using free Cloudflare.
    2. I’m using OpenLiteSpeed.
    3. I have disabled WP-Cron and using server real cron job to run every 3 min. My cron job is running well by testing to run test scheduled posts. Worked 10 times out of 10.
    4. My LiteSpeed cache is working by checking “x-litespeed-cache: hit”.
    5. This happened to all my sites.

    Report Number: GDKXVZTR

    Please kindly help me fix this issue. Thanks in advance.

    Best regards,

    Shah

    • This topic was modified 2 years, 2 months ago by Shah Ahmad Yusof.
    • This topic was modified 2 years, 2 months ago by Shah Ahmad Yusof. Reason: Add report number
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    the report you provided , I only see 1 images in that site.

    Could you please try upload few more images and run optimization ?

    Best regards,

    Thread Starter Shah Ahmad Yusof

    (@shahahmadyusof)

    Hi @qtwrk ,

    Thank you for your reply. I just uploaded 6 more images using 2 of the same images (Image 1, Image 2, Image 3, Scene 1, Scene 2, Scene 3) for testing purposes. And I also check that:

    1. None of the 6 images above have a webp version.
    2. None of the 6 images above have an original backup which I cannot revert to the original.
    3. Only 3 of the images are well optimized while the other 3 are only optimized 1% only.

    I also tried using other image compressor plugins and it is working well. Please kindly help me look into this. Thanks.

    Best regards,

    Shah

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    1) in some case, webp will be larger than origin , in such case, webp will be dropped

    2) Did you remove origin images ?

    3) some images could be pre-optimized already before upload , in this case there won’t be much room to improve.

    Best regards,

    Thread Starter Shah Ahmad Yusof

    (@shahahmadyusof)

    Hi,

    1) in some case, webp will be larger than origin , in such case, webp will be dropped

    That’s what I thought before. But I did convert optimized and unoptimized of the same images to webp using third party websites such as ezgif and online-convert and it did converted to lower size.

    2) Did you remove origin images ?

    Nope, I didn’t. All I did is just click on the “Gather Image Data” and “Send Optimization Request”. Since this is new site, feel free to try and upload new images and see if things looking different on your side.

    3) some images could be pre-optimized already before upload , in this case there won’t be much room to improve.

    I agree. But all images I upload to my WordPress is unoptimized. If I tried to optimized these images using TinyPNG etc, it can lower more than half size.

    This has happened to all my sites now. Everything was working perfectly before moving host. On my other site, there are images that are perfectly optimized, have webp version and have backup images which was uploaded before I move host. And I still have the exact copies of these images on my computer. If I tried to reupload these same images, it is either optimized only 1%, no webp version or no original backup.

    The only think I suspected which caused this is because of I’m using memory swap files. But I could be wrong. I have tried disabling my swap files, but database is always crashed after few mins without swap files. My RAM is only 1GB. Please help me look into this.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    1) and 3) might be due to different algorithm , but in our case, it’s hard-coded setting

    2) I did try test few images and it works properly on my test.

    Could you please try create a new wordpress in subdirectory , upload few images there and see if origin gets removed ?

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    I’m going to mark this topic “Resolved”, due to lack of activity.

    If you still need help, please feel free to re-open it.

    Best regards,

    Thread Starter Shah Ahmad Yusof

    (@shahahmadyusof)

    Hi @qtwrk ,

    I’m going to mark this topic “Resolved”, due to lack of activity.
    If you still need help, please feel free to re-open it.

    I’m sorry for the late reply. I just come back from a remote place where there’s no internet. It seems my issue has fixed once I reached home. It is probably caused by the slow internet there. Anyway, thank you for your assistance. You are super awesome!

    Best regards,

    Shah.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘New images uploaded not optimized.’ is closed to new replies.