Support » Fixing WordPress » New Images don't show after upgrade to 3.3

  • Resolved Vikram


    Hi there,

    I am running WordPress 3.3 in a multisite environment. After upgrade to 3.3 today, any new images that are uploaded to the site don’t display in the browser. It returns a 404. (Oddly, some images do display but only display half way). You can see the problem here:

    I have deactivated all plugins and that has not made any difference.

    Any pointers appreciated!


Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi Vikram,

    I first looked at the image that didn’t load all the way:

    The image is loading 100%, but it appears the upload was corrupted some how as only the top part of the image made it through. That makes sense too because in the url the size says 430×678, and the “half” image itself is 430×678.

    Have you tried both upload options in WordPress 3.3 to see if one works better than the other? For example, if you’re using the flash uploader, try to browser uploader option instead.

    Please let us know if that helps or not.

    Thanks for the great tip Brad.

    I checked the files on the server, and they are indeed corrupted somehow. Interestingly, one of the auto generated resized version is ok.

    I then tried the browser upload, and that had the same issue.

    However, I tried uploading another file and that worked well on both uploads.

    See these:
    and this:


    this is really strange issue. both up-loader option never create this issues. please let me know what operating system you are using. please try to upload image from another system and update result. I doubt its some virus issue on system. also you can try another browser.

    Thanks Pankaj. Yes it is very strange.

    I am on RHEL5 + Apache 2.2. I have tried to upload the images from another browser. Same issues. I am not sure what you mean by uploading from another system, via FTP? That works fine.

    I have not had this problem before the upgrade today.


    Hi Vikram,

    Ipstenu as posted a good troubleshooting guide for WordPress 3.3 which can be found here:

    Troubleshooting WordPress 3.3 – Master List

    … although I don’t believe any of the items listed may help in this scenario, I recommend giving it a quick read.

    I would also recommend trying some of the standard troubleshooting techniques, as you may have a theme / plugin that is conflicting somehow with the new version of WordPress:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    An update (it just keeps getting stranger!):

    I tried to upload two different sizes of the same image:

    This one gets corrupted:

    This one uploads ok:

    The difference? The first one that doesn’t work is around 100 KB in size and the second one that works is reduced to 20 KB. I tried uploading the same image at reduced sizes from 100 down to 20 KB, and 20 KB seems to be when it worked.

    I am quite confused! Nothing AFAIK, has changed on the server besides the 3.3 upgrade!


    Thanks again Brad. I have tried most of those options. I am now trying to reset the plugins folder.


    Ok, here is a curve ball!

    The images are not corrupted! If I download those same images which appear to be corrupted and truncated via FTP, they are perfectly normal images.

    I am really stumped now! Even the images that I had shown earlier in this topic as corrupted, some of them appear normal to me now.


    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Are you using a Macintosh?

    @ipstenu – The server is RHEL. The clients are mostly windows, but almost everyone is reporting the issue.


    @ipstenu, if we think there is a bug, how can we offically report it? Is there a page that outlines what we should check before hand, etc?

    @gvix, to determine if this is a server issue or not, are you able to create a fresh 3.3 install on your same server somewhere and test the upload functionality?

    Overnight, I think I have narrowed it down to a bug in ms-files.php. It is still not completely solved. Some images still refuse to display properly,
    in spite of uploading them again.

    It is confirmed by the fact that the images are actually perfectly ok if I download them via FTP.

    There is some more info here:

    If anyone has any other pointers, I would really appreciate it!


    If anyone else has the same problem, where some images appear corrupt or would not display after upgrade to WordPress 3.3, we narrowed it down to a bug in ms-files.php. It has the readfile($file) code, which somehow doesn’t seem to output the image to the buffer properly (only some images).

    Although our solution was not the best one, we found that by increasing the available buffer in php.ini (change the value of output_buffer variable) to a high enough value, we were able to work around this issue. the value that you need to set will depend on the images that you display.

    It is not a solution, and there should be a way to bypass the use of ms-files.php to serve images (or better still the bug needs fixing).

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘New Images don't show after upgrade to 3.3’ is closed to new replies.