WordPress.org

Support

Support » Plugins and Hacks » [Resolved] New host: missing: jpegtran, optipng, gifsicle.

[Resolved] New host: missing: jpegtran, optipng, gifsicle.

  • Hi guys.

    i just moved hosting providers and now i got a few problems.

    its saying i am missing: jpegtran, optipng, gifsicle.
    i tried the jpegtran: Install automatically but it says: jpegtran was not installed, check permissions on the wp-content/ewww folder.

    Here is the plugin/debug info: (Any help will be greatful. thanks)

    jpegtran: MISSING Install automatically | manually
    optipng: MISSING Copy binary from /var/sites/g/geekstech.co.uk/public_html/wp-content/plugins/ewww-image-optimizer/ to /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/ or Download optipng source
    gifsicle: MISSING Copy binary from /var/sites/g/geekstech.co.uk/public_html/wp-content/plugins/ewww-image-optimizer/ to /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/ or Download gifsicle source
    Graphics libraries (only used for conversion, not optimization): GD: OK   Imagemagick ‘convert’: MISSING
    safe mode: Off  exec(): OK  shell_exec(): OK  file command not found on your system
    Only need one of these: finfo: MISSING  getimagesize(): OK  mime_content_type(): MISSING
    Debug Info

    jpegtran path:
    optipng path:
    gifsicle path:
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755
    user:
    Operating environment: Linux 2.6.32.21-grsec #6 SMP Fri May 20 17:37:06 BST 2011 x86_64

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author nosilver4u

    @nosilver4u

    Was the ‘user’ part blank on the settings page, or did you remove that before you posted it?

    Plugin Author nosilver4u

    @nosilver4u

    Ah, if I would take my time, I would have seen the error the first time. Your server does not have the ‘file’ command installed. Do you have access to install software, or can you ask your host to make sure that command is installed?

    I only have SSH access (shared hosting you see)

    If it can be via SSH what do i need to type in?
    If i need to ask my host, i take it just need them to install ‘file’ command

    UPDATE

    I just asked my host and they said file is installed
    it’s at /usr/bin/file

    P.s: Yes the ‘user’ part was blank on the settings page

    Plugin Author nosilver4u

    @nosilver4u

    Put this in a .php file, and see what it says:

    <?php
    echo shell_exec('file /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/optipng');
    ?>

    This is what it says:

    /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/optipng: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, statically linked, for GNU/Linux 2.6.9, from ‘mplete’, not stripped

    TBH i am getting a few errors with this host, so i might switch back to my old host until i find another host.

    Would it have anything to do with cloud hosting? as that is what i am hosted on ATM

    Plugin Author nosilver4u

    @nosilver4u

    It depends a LOT on the webhost. Some will put restrictions on what and where you can run executables, some remove normal default system utilities, or modify them to be unrecognizable. I would be curious to see what the result of this php is:

    <?php
    echo 'start..' . shell_exec('file -v 2>&1') . '..end';
    ?>
    Plugin Author nosilver4u

    @nosilver4u

    Also, just to be sure that the executables run, try these commands via ssh:

    /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/optipng -v
    /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/gifsicle --version
    uname -a

    First one i get the following

    start..sh: file: command not found ..end

    the i ran the stuff in the 2nd post in SSH and i got the following

    1:

    bash-3.2$ /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/optipng -v
    OptiPNG version 0.7.4
    Copyright (C) 2001-2012 Cosmin Truta and the Contributing Authors.

    This program is open-source software. See LICENSE for more details.

    Portions of this software are based in part on the work of:
    Jean-loup Gailly and Mark Adler (zlib)
    Glenn Randers-Pehrson and the PNG Development Group (libpng)
    Miyasaka Masaru (BMP support)
    David Koblas (GIF support)

    Using libpng version 1.4.12 and zlib version 1.2.7-optipng
    bash-3.2$

    2:

    bash-3.2$ /var/sites/g/geekstech.co.uk/public_html/wp-content/ewww/gifsicle –version uname -a
    LCDF Gifsicle 1.68
    Copyright (C) 1997-2011 Eddie Kohler
    This is free software; see the source for copying conditions.
    There is NO warranty, not even for merchantability or fitness for a
    particular purpose.
    bash-3.2$

    TBH mate, i am going to switch back to my old hosting and quicky research for another (reached my limit with the old host you see)

    Well i hope the above info well help you and others with the same problem later on now down the road.

    I will agree (which what i thought in the first place) the problem is down to the host.

    Thanks again for all your help m8.

    GREAT SUPPORT

    Plugin Author nosilver4u

    @nosilver4u

    Thanks for the information, it appears that they are running some fancy setup with apache where the user that runs the apache process doesn’t have a ‘path’. What that means (and I don’t think it is all that uncommon), is executables/binaries must always have their full path specified. I’m running into this with porting the plugin to FreeBSD, so your information will help me in making version 1.4.0 better for linux webhosts too.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] New host: missing: jpegtran, optipng, gifsicle.’ is closed to new replies.