Support » Plugin: Pronamic Google Maps » New Google policy asking for a Credit Card to use the Maps API

  • Resolved Jan444

    (@ign2009)


    Hi friends, thanks for this great plugin that we are using since many years.

    This summer Google started asking for a Credit Card to use their Maps APIs.
    However our site works just fine so far, and no downgraded experience has happened.

    Why is it? We haven’t provided any Credit Card.

    In another site that is using Maps via a Theme we are having problems because of that, but not in the site where we use Pronamics Google Maps.

    Thanks for any input,

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘New Google policy asking for a Credit Card to use the Maps API’ is closed to new replies.