Support » Plugin: WP Mail SMTP by WPForms » New error with today’s update

  • Resolved bitpath

    (@bitpath)


    This seemed to work fine for years i believe. Today, after updating it, my site went blank. I deleted the plugin to get my site back up. I re-installed from the repository and it triggered a fatal error attempting to activate with the below full error:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected ‘[‘ in /var/www/html/wp-content/plugins/wp-mail-smtp/vendor/guzzlehttp/psr7/src/functions.php on line 78

    This is the first time I received such an error from this plugin. It’s been so great for so long, up until today’s update. Hope this gets fixed soon. Thank you!

Viewing 15 replies - 1 through 15 (of 31 total)
  • Plugin Author Jared Atchison

    (@jaredatch)

    Thanks for the report, apologize about that.

    Would you let us know what version of PHP your site is using?

    Thread Starter bitpath

    (@bitpath)

    It looks like 5.3.10. I can upgrade that by upgrading the underlying Linux LTS version tonight. Does that sound like the issue?
    Thank you

    We have the same issue with PHP version 5.3.10.

    Is it possible to rollback to a prior version (1.2.5) until this is resolved?

    This plugin using out of date or wrongly configured google-api-php-client , not listening to the users. Nothing to do with the php version.

    https://github.com/google/google-api-php-client

    • This reply was modified 2 years, 8 months ago by xfoxx.
    • This reply was modified 2 years, 8 months ago by xfoxx.
    • This reply was modified 2 years, 8 months ago by xfoxx.

    We are getting the exact same error after updating the pluggin. Entire site is offline now. Using PHP 5.3 on IIS8

    Can’t even login to the WP admin panel anymore so we can’t roll back the update.

    Thread Starter bitpath

    (@bitpath)

    xfoxx, forgive me for not understanding completely. Are you saying a Google update to an API this uses caused things to break?
    And thank you Jared for any advice as well!

    • This reply was modified 2 years, 8 months ago by bitpath.
    • This reply was modified 2 years, 8 months ago by bitpath.
    Thread Starter bitpath

    (@bitpath)

    juanchopancho I got our site back up by logging in with an SFTP program to directly go to …/siteroot/wp-content/plugins/ and delete the wp-mail-smtp folder from there. You can also SSH in, or if you have cpanel access you can delete it that way too. That should deactivate this plugin and let your site come back online, if it’s the same issue.
    Deleting that folder got things back up. After I reloaded the plugin from the wordpress repository, it failed to activate with the error I posted, so I came here.
    It’s a great plugin so I hope we can reactivate it.
    Hope this helps!

    • This reply was modified 2 years, 8 months ago by bitpath.
    • This reply was modified 2 years, 8 months ago by bitpath.

    @bitpath @juanchopancho You don’t have to delete the file, just sftp into the site and rename the folder and your site will restart. You can’t re-enable the plugin until a new fix is pushed or an older version is made available.

    Plugin Author Jared Atchison

    (@jaredatch)

    The error reported by @bitpath is caused by the PHP version. If you are encountering a different error please create another thread.

    PHP “shorthand” array syntax (eg $foo = [ 'bar' ], instead of $foo = array( 'bar' )) is only supported by PHP 5.4+ – that is what you will find if you follow the path of that error message.

    Here’s the issue: The official PHP Google API uses several 3rd party dependancies, for example guzzlehttp. We regularly update the Google API and dependancies packaged with our plugin when we do updates to keep things running smooth, bug free, and up to date security wise. In this case it appears that at least one of the dependancies has dropped support for PHP 5.3, this now causes a fatal error.

    We’ll look into what our options are tomorrow; obviously we don’t want to break sites.

    In the mean time, if possible, I highly recommend you upgrade PHP versions. I can’t stress this enough. Usually it’s a simple as asking your web host. Not only would this fix the issue, but more importantly it would make your site faster and more secure.

    Any PHP version less than 5.6 is labeled “end of life” and is not supported anymore. This means it does not get security patches or updates – Yikes! For example the last update for PHP 5.3 was almost 4 years ago, 5.3.10 was released in 2012.

    (For more info about PHP versions see http://php.net/eol.php)

    With all that said, you can definitely roll back until we have a fix out, if updating PHP isn’t feasible.

    On the WP Mail SMTP plugin page, go to Advanced (https://cl.ly/43321D403Z3v), and look for the “PREVIOUS VERSIONS” at the bottom of the page. Select 1.2.5 and it will download the previous version.

    Thread Starter bitpath

    (@bitpath)

    Thank you.
    I have complete control of the sites broken I manage of course. I just wanted to know what happened. And I respect and appreciate you even more now.

    • This reply was modified 2 years, 8 months ago by bitpath.

    I’m on php 7 and use other plugins, that use google-api-php-client and they are fine.
    Deleted the plugin now anyway, author not listening to anything

    Thread Starter bitpath

    (@bitpath)

    Jared is amazin. If I had money I’d be all about supporting his free effort..

    Same issue with PHP 7.0.27

    Plugin Author Slava Abakumov

    (@slaffik)

    Hey @bitpath and @johnmellis and @juanchopancho and @websico,

    I’m working on it, the fix will be released within hours (if not less).

    Plugin Author Slava Abakumov

    (@slaffik)

    @xfoxx,

    I see that you are a not a developer, so it would be very complicated for me to explain to you the roots of your issue.

    But please, create a SEPARATE thread to discuss your issue if you want to, and do not pollute unrelated threads with your opinions and incorrect observations.

    In any case, please be calm and polite, we don’t owe you anything.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘New error with today’s update’ is closed to new replies.