Support » Plugin: Fast Velocity Minify » New error when trying to edit or create a new page with Elementor Pro

  • Resolved hkim00

    (@hkim00)


    After updating to the latest versions of Elementor and FVM, I’m getting following error message when I try to edit or create a new page:

    Notice: Undefined index: post_type in /home/nginx/domains/mydomain.com/public/wp-content/plugins/fast-velocity-minify/inc/functions.php on line 805

    This messes the formatting of the page header but I cannot see any other malfunctions. What can be wrong?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Correction: It only mess up the formatting of the header during editing the page, not the final result.

    In /inc/functions.php you have added a new function:

    
     # elementor
            if(isset($_GET['elementor-preview']) && $_GET['post_type'] == $a) { return true; }
            if(is_array($_GET)) {
                    foreach ($_GET as $k=>$v) {
                            if(is_string($v) && is_string($k)) {
                                    if(stripos($k, 'elementor') !== false || stripos($v, 'elementor') !== false) {
                                            return true;
                                    }
                            }
                    }
            }

    There seems to be something wrong with this since the post_type is not recognized when I edit pages/posts in the latest version of the elementor.

    See picture: https://www.dropbox.com/s/kxtuz4pu8bhl5dr/error.JPG?dl=0 displaying how it looks when I edit a page in Elementor. The header is not all that wide. The formatting is ok when diplaying the published page, but not when I’m editing.

    • This reply was modified 7 months, 3 weeks ago by hkim00.

    Well the error message was showing since I had debug on in wp-config.php. But why am I getting the error message at all?

    Plugin Author Raul P.

    (@alignak)

    @hkim00 do you have the “fix page editors” option enabled?

    Well, that “notice” on PHP is because I forgot to add a check to see if it exists, before actually doing something with it. It should not show up, unless you have wp_debug enabled (should be off by default) and it’s not an error, but rather a notice (something not critical).

    I’ll push an update for this in a couple of days, so meanwhile simply disable wp_debug and it should go away.

    Yes you are correct: a) I have “Fix Page Editors” enabled and b) I have wp_debug enabled. I have now disabled wp_debug and no more errors. Thank you for your reply!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘New error when trying to edit or create a new page with Elementor Pro’ is closed to new replies.