Support » Plugin: CF7 Google Sheets Connector » New entries are not in correct columns

  • Resolved dshiver007

    (@dshiver007)


    Within the last two days, we’ve run into a problem with this plugin (the free version) that was never an issue before.

    On submission of the contact form, fields are no longer going to the correct column in our Google Sheet. Specifically, the entire row seems offset by a random number of columns. Within the row itself, the data appears fine – it’s just shifted right.

    The consequence is that, instead of all rows starting in Column A, we have some starting randomly in Column J, or AB, or BD, for example. It seems the offset is always increasing with each new row appended to the Google Sheet. This is making a mess of our Google Sheet as none of the new entries are putting data into the correct columns.

    We are using the latest versions of Contact Form 7 and the Google Sheets Connector. Our Google sheet is 45 columns wide and currently has over 350 rows.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author westerndeal

    (@westerndeal)

    Hello @dshiver007
    Sorry for the trouble and glitch issue.

    Have you added any scripts or formulas in the sheet?
    Can you try once while creating a new sheet and link the new sheet with the same contact form and let me know if still, issues exist

    Thanks
    Abdullah

    Plugin Author westerndeal

    (@westerndeal)

    Hello @dshiver007

    Have you tried while using new fresh sheet?
    please do let me know so that I can help you out further.

    Thanks
    Abdullah

    Hi @westerndeal, yes I tried a fresh sheet (no data) with the same column names and it appears to be working. However, I want to keep all my data in one place. Is there any way I can get the existing sheet working, the one that already has my data in it? There are no formulas in the sheet. Thanks.

    Plugin Author westerndeal

    (@westerndeal)

    Hello @dshiver007
    Earlier you mentioned you are getting data but cell shifted to the right and not getting appropriate entries in a particular column,
    Now, In a new sheet, even data is not filling?
    Please explain along with screenshot to help you out.

    Before that can you try reauthenticating with google once again?
    Make sure first deactivate and also remove access from the permission
    https://myaccount.google.com/permissions
    Then Reauth Once and try with new sheet once and let me know what exactly issue you have.

    Hi again,

    In the new fresh sheet the entires are going into the correct columns.

    However, I would like to continue using my existing sheet. How can I continue to use my existing sheet (with data) without having the new entries shifted?

    Thank you.

    Plugin Author westerndeal

    (@westerndeal)

    Hello @dshiver007

    Thanks for confirming,
    You can delete headers and reenter properly and then try again.
    Sometimes it may happen if using any scripts or macros etc. Its recommended not to use scripts on connected sheets.

    Thanks

    Thanks for the suggestion.

    I tried deleting the headers and reentering them, and the entires are still going into the wrong columns. I have no scripts or macros on the Google sheet.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.