Support » Plugin: WooCommerce » New endpoints not working

  • Does not appear that the new endpoints are working. I have flushed permalinks, applied the latest 2.1.1 and flushed permalinks…

    Any link that points to any of the new endpoints results in a redirect… example…

    If you are on the /my-account/ page and click view for the order’s details, it simply redirects back to /my-account/. This is true for the lost password, edit billing, edit account, etc…

Viewing 13 replies - 1 through 13 (of 13 total)
  • I am having the same problem. Useless as is.

    I have also tested if a customer completes an order, it simply redirects them to an empty cart, no thank you.

    Has anyone been able to resolve this issue yet?

    Just to add a bit more info. Woo says the below fixes 404s… which I never had 404s and have applied the latest version… Still no fix for my situation. Seems others are having the exact same issue as well.

    Lots of pages 404 error after WooCommerce 2.1 update

    This issue is now resolved in the WooCommerce 2.1.1 fix release.

    Because we have changed a couple static pages to endpoints in the WooCommerce 2.1 release, the permalinks need to be flushed. This wasn’t done properly in the WooCommerce 2.1 update, therefore you should do this manually in case you have a lot of 404 errors after updating. The upcoming 2.1.1 patch release will fix this issue and no longer requires a manual flush.

    Pages included in possible 404 errors are: main shop page, category or tag archives and all of the new endpoints. This also affects conditional functions like is_shop() and that causes plugins relying on that function to no longer function properly.

    You can flush the permalinks manually by saving the Settings > Permalinks page, to be found in your WordPress administration panel. After doing this, your pages will work as expected.

    @indyjoey I don’t know if this will help, but I was experiencing the same redirection issue. When I entered the endpoint link into the browser, I would be redirected to the broken shortcodes on the My Account page.

    Once I added the [woocommerce_my_account] shortcode into the My Account page and deleted the other shortcodes, I was then able to see the missing content e.g. /my-account/edit-address, /view-order, etc

    The templates for these endpoints are in plugins>woocommerce>templates>myaccount

    It was a simple fix for me, but a long journey to find the answer. Hope that helps.

    jillmugge, this solution did not work for me. I am using the newest version. 2.1.2

    This is what worked for me

    basically I checked each plugin one-by-one and flushed (saved) the permalinks in the correct settings EACH TIME. Then refreshed the 404 page after and it wound up being the last plugin on my list, been working on this for days, so happy to have it fixed.

    The flushing (saving) of permalinks is a very important step, and has to be done for every change. A good lesson for the future.

    the plugin that was an issue for me was WP Video (sorry deleted it so I don’t have the rest of the info for the plugin)

    I don’t know if this is the same problem, but whenever a customer checks out, they get a “result,failure, message, session has timed out.etc…. and a bunch of customer fields. I assume it is the order receieved endpoint. Is this what you all are experiencing on the checkout?

    My change password endpoint is missing and the option to change the password link in my account is not working.

    I’ve the same problem! I’ve already updated the plugin to the 2.1.2 version but i still get 404 for every endpoint.

    Anyone found a solution for this?

    I have the same problem after the update, the permalinks of my-account/… give me a 404 error. They only work if I change the setting of the permalinks to default.

    The only thing that have worked for me is adding this code to the functions.php file of my template, but if I delete the code the permalinks on my-account/ break again and I don’t like this solution.

    function flush_rules(){

    any idea where the problem is?

    ok, I’ve found the problem, it was a plugin.

    Thanks Ibain your solution worked for me!
    I think that the first time I tried this, I did not flush the permalinks every single time with each plugin.

    You could also put rewrite rules in .htaccess to solve this issue. eg

    RewriteRule ^my-account/lost-password/ wp-login.php?action=lostpassword

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘New endpoints not working’ is closed to new replies.