Support » Plugin: Duplicate Post » New duplicate or cloned pages not updating permalink when saved

  • Resolved Mitch Menghi

    (@menkom)


    Hi Enrico, i donated to you some time ago because of how good your plugin is, i am sorry to say that in recent times your plugin is not working as expected anymore.

    Steps to reproduce…

    When i select CLONE or DUPLICATE it goes to the new page created the slug is the same slug as before but with a -2 at the end so example privacy-2

    I enter in the new title and modify content, then click publish.

    At this point your plugin used to update the slug to the new title slug, however it does not do this anymore and i need to physically enter in a new slug myself which i never had to do before.

    I am using the Divi theme if that makes anything easier to resolve.

    Hope this is resolved, it has happened on multiple Divi theme sites ive recently tried your plugin on.

    Regards,
    Mitch

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Lopo

    (@lopo)

    Hi @menkom,
    have you tried disabling the Slug checkbox under SettingsDuplicate Post, tab What to copy, then saving the options and trying again?

    Let me know if this helps!

    • This reply was modified 1 year, 2 months ago by  Lopo.

    Hi @lopo this has resolved my issue, thank you so much, joy to the world again… i really do think this needs to be unchecked by default as i believe in the majority of the cases the slug would want to change to the new page title. 🙂

    Plugin Author Lopo

    (@lopo)

    Yes @menkom, it will be fixed in the next version, probably with a warning like the one regarding the Attachments setting.
    Thanks for your help and appreciation!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘New duplicate or cloned pages not updating permalink when saved’ is closed to new replies.