WordPress.org

Support

Support » Plugins and Hacks » New custom fields not displaying

New custom fields not displaying

Viewing 15 replies - 1 through 15 (of 32 total)
  • Exactly the same problem here when I updated to 3.5.4.1
    Newly added fields are not displaying.
    Same problem when I updated from another wordpress setup too.

    Exactly the same problem here with 3.5.4.1 update.

    Plugin Author elliotcondon
    Member

    @elliotcondon

    Hi guys,

    So when you add new fields to a field group and update the field group, the fields are not being saved?

    Hi Elliot, thanks for the reply.
    Yes exactly.
    However in the previous page “Field Groups” the field number indicator for each group is correct IF the fields are 3 or less.
    Same issue if you create a new group and then add a field.
    When you click publish/update the field disappears from the “field order”.
    (I am in localhost)

    I haven’t looked in the db to see if they are saving. I think they might be. I noticed the correct number was showing up in the field groups setting page, but the custom fields were not displaying on the post editor and not showing up individual field group editors. It could be what Miltos-S is saying about the 3 or less, too.

    I reverted back to the previous version without any issues.

    I just reverted back to 3.5.3 and the problem goes away here too.

    Plugin Author elliotcondon
    Member

    @elliotcondon

    Hey guys

    I would realy like to getthis bug fixed before more people experience it.

    Any chance you can create me and admin account and email the details to support@advancedcustomfields.com

    If i can test whats happening i can fix the issue asap.

    Thanks

    Ok… problem solved!
    This is not an ACF issue.
    In my case it was the php tags in my functions.php
    If you have space before or after the tags probably this causes the problem.

    I’ll have to check all my code, but my functions.php is not the issue.

    I reverted to 3.5.3 too. The problem goes away ofc.

    petercarlill
    Member

    @petercarlill

    Hi Elliot.

    I have this same issue on a fresh install of 3.5.4.1.

    Did you get a chance to look at an installation? If not I’ll pop you over some account details.

    Hi guys,

    I’m getting the same issue with 3.5.4.1. Where can I download a past release to roll back to?

    Thanks,
    Alex

    Thanks Eric!

    After cleaning up my functions.php the issue was solved for me.
    To figure out if the problem was in my theme I did 2 things.
    First I deactivated my theme and activated the twenty eleven theme. The problem was gone.
    Second I reactivated my theme and temporarily emptied my functions file. The problem was gone again.
    Some ideas that you may have already tried:
    If you have multiple php tags in the functions try to eliminate them by having only one opening tag at the beginning and a closing at the end.
    If you have other php files included in the functions check them too.

    The only thing I wonder is why the previous version was working fine even without doing anything of the above…
    Anyway maybe it was a chance to clean up my code a bit…!

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘New custom fields not displaying’ is closed to new replies.