WordPress.org

Forums

Fast Secure Contact Form
New CAPTCHA won't display (5 posts)

  1. forehandfrenzy
    Member
    Posted 8 months ago #

    Okay, I have tried the url fixes you suggested but I was unable to find a solution. I have tried changing to the twenty thirteen theme and I have tried the .htaccess solution to no avail. When clicking on the captcha image I am getting this:

    Warning: session_start() [function.session-start]: SAFE MODE Restriction in effect. The script whose uid is 649 is not allowed to access /tmp owned by uid 0 in /home/forehand/domains/forehandfrenzy.com/public_html/wp-content/plugins/si-contact-form/captcha/securimage.php on line 427

    Fatal error: session_start() [function.session-start]: Failed to initialize storage module: files (path: ) in /home/forehand/domains/forehandfrenzy.com/public_html/wp-content/plugins/si-contact-form/captcha/securimage.php on line 427

    Any suggestions would be greatly appreciated.

    https://wordpress.org/plugins/si-contact-form/

  2. mbrsolution
    Member
    Posted 8 months ago #

    Hi forehandfrenzy can you check the folder's permission on the following path

    is not allowed to access /tmp

    Let me know if that helps you.

    Kind regards

  3. Mike Challis
    Member
    Plugin Author

    Posted 8 months ago #

    PHP Sessions are broken on your server, so lets turn that feature off so the form will not try to use it..
    Go to the form edit page advanced tab, uncheck this setting:
    Enable PHP sessions
    then click save changes

    This is a global setting that affects all forms.

  4. forehandfrenzy
    Member
    Posted 8 months ago #

    Okay, not able to find a /tmp folder on the server to change permissions. Not sure if I am just not finding it or if it isn't there. Also, I disabled PHP settings and I'm still not able to see the CAPTCHA image.

  5. Mike Challis
    Member
    Plugin Author

    Posted 8 months ago #

    If you have cache plugin, be sure to clear the page cache.

    The session error is because the PHP server has safe mode enabled. Safe mode should not be enabled, it does nothing to enhance security and breaks too much functionality.

    The PHP sessions setting in my plugin is supposed to be unchecked by default.

Reply

You must log in to post.

About this Plugin

About this Topic