WordPress.org

Support

Support » Plugins and Hacks » [Resolved] New Bug Filling Up Log Files Taking Down Site – 20gig And Counting

[Resolved] New Bug Filling Up Log Files Taking Down Site – 20gig And Counting

  • john

    @johnpaulbeaver

    Yay a new site debilitating bug has appeared after running 2.0.27 for a while! Our log files are now filled with 20gig and growing of the following:

    PHP Warning: next() expects parameter 1 to be array, integer given in /wordpress/htdocs/wp-includes/plugin.php on line 408
    PHP Warning: current() expects parameter 1 to be array, integer given in /wordpress/htdocs/wp-includes/plugin.php on line 404
    PHP Warning: next() expects parameter 1 to be array, integer given in /wordpress/htdocs/wp-includes/plugin.php on line 408

    Guess what happens when next-gen is disabled? That’s right, the error goes away!

    http://wordpress.org/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 56 total)
  • btuck044

    @btuck044

    Same exact thing happening here with the newest version over 2.0 We had a log file reach up to 24GB. Had to roll back to version 1.9.1 Next Gen gallery. Caused major problems.

    Please get this issue resolved with the next release.

    lizgent

    @lizgent

    Exactly the same problem here – I got warning email from my website host that I had an error log which was 9gb of:-

    [21-Sep-2013 18:09:03 UTC] PHP Warning: next() expects parameter 1 to be array, integer given in…wp-includes/plugin.php on line 408

    I’ll have to disable next-gen.

    john

    @johnpaulbeaver

    Unfortunately, it will be difficult for a lot of people to realize that next-gen is the source of their log file drama as the warning doesn’t explicitly show the origin of the error.

    I hope a fix for this will come sometime today as it is a site debilitating problem.

    [Moderator Note: No bumping, thank you.]

    ilcarota

    @ilcarota

    i checked my log inside the worpress folder. it grows with this error:

    [23-Sep-2013 20:44:20 UTC] WordPress errore sul database Table ‘XXXXXXXX_wp1.wp_’ doesn’t exist per la query DELETE FROM wp_ WHERE option_name LIKE ‘%%displayed_galleries_%%’ AND option_value < 1379969060 fatta da do_action_ref_array, call_user_func_array, C_NextGEN_Bootstrap->delete_expired_transients, C_Photocrati_Cache::flush, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query

    where XXXXX is my database…

    also i have this error:

    WordPress errore sul database You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘) ORDER BY RAND() LIMIT 9’ at line 1 per la query SELECT pid FROM wp_ngg_pictures WHERE exclude = 0 AND galleryid IN () ORDER BY RAND() LIMIT 9 fatta da require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), include(‘/themes/pinboard/index.php’), get_sidebar, locate_template, load_template, require_once(‘/themes/pinboard/sidebar.php’), get_sidebar, locate_template, load_template, require_once(‘/themes/pinboard/sidebar-top.php’), dynamic_sidebar, call_user_func_array, WP_Widget->display_callback, C_Widget_Gallery->widget, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query

    smmcats

    @smmcats

    Same problem here, it has just started randomly affecting websites that I have created for customers. I’m uploading an older version to see if it does the same thing. This is a major pain.

    Kerwood

    @kerwood

    Same problem here.. 20GB+ log file.

    I modified this linje, as a temorary solution. Worked for 24 hours now.

    Original line
    while ( next($wp_filter[$tag]) !== false );

    Modified
    while ( is_array($wp_filter[$tag]) && next($wp_filter[$tag]) !== false );

    Hope they will fix it soon.

    lorenzoali

    @lorenzoali

    I’m having same problem since updating the NextGEN plugin last week. Any idea when this will be fixed or a long term solution? Here is the error log script:

    [24-Sep-2013 07:50:45 UTC] WordPress database error Table 'lorenzop_wp1.wp_' doesn't exist for query DELETE FROM wp_ WHERE option_name LIKE '%%displayed_galleries_%%' AND option_value < 1380009045 made by do_action_ref_array, call_user_func_array, C_NextGEN_Bootstrap->delete_expired_transients, C_Photocrati_Cache::flush, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query
    [24-Sep-2013 07:56:41 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'minimum_home_genesis_meta' not found or invalid function name in /home/lorenzop/public_html/wp-includes/plugin.php on line 406
    [24-Sep-2013 08:30:39 UTC] WordPress database error Table 'lorenzop_wp1.wp_' doesn't exist for query DELETE FROM wp_ WHERE option_name LIKE '%%displayed_galleries_%%' AND option_value < 1380011438 made by do_action_ref_array, call_user_func_array, C_NextGEN_Bootstrap->delete_expired_transients, C_Photocrati_Cache::flush, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query
    [24-Sep-2013 09:29:02 UTC] WordPress database error Table 'lorenzop_wp1.wp_' doesn't exist for query DELETE FROM wp_ WHERE option_name LIKE '%%displayed_galleries_%%' AND option_value < 1380014942 made by do_action_ref_array, call_user_func_array, C_NextGEN_Bootstrap->delete_expired_transients, C_Photocrati_Cache::flush, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query
    [24-Sep-2013 10:28:59 UTC] WordPress database error Table 'lorenzop_wp1.wp_' doesn't exist for query DELETE FROM wp_ WHERE option_name LIKE '%%displayed_galleries_%%' AND option_value < 1380018538 made by do_action_ref_array, call_user_func_array, C_NextGEN_Bootstrap->delete_expired_transients, C_Photocrati_Cache::flush, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query
    [24-Sep-2013 11:01:05 UTC] PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'minimum_home_genesis_meta' not found or invalid function name in /home/lorenzop/public_html/wp-includes/plugin.php on line 406
    [24-Sep-2013 11:28:59 UTC] WordPress database error Table 'lorenzop_wp1.wp_' doesn't exist for query DELETE FROM wp_ WHERE option_name LIKE '%%displayed_galleries_%%' AND option_value < 1380022139 made by do_action_ref_array, call_user_func_array, C_NextGEN_Bootstrap->delete_expired_transients, C_Photocrati_Cache::flush, W3_Db->query, W3_DbCache->query, W3_DbCallUnderlying->query, W3_Db->query, W3_DbProcessor->query, W3_Db->default_query

    [Moderator Note: Please post log files between backticks or use the code button.]

    Plugin Author photocrati

    @photocrati

    All – Database issues are extremely important for use to sort out and error_log messages are also very important for our developers to get a look at.

    We ask you to please submit Bug Reports for these issues with your specific details. We would also greatly appreciate if you could share a set of log in credentials for your WordPress installation as well as FTP credentials for your WordPress installation folder in these cases.

    Thanks!

    – Cais.

    @kerwood,
    would you please share which file have you modified to fix this issue?
    Thank you!

    Having the same problem:

    [24-Sep-2013 11:20:48 UTC] PHP Warning:  current() expects parameter 1 to be array, null given in /home/username/public_html/wp-includes/plugin.php on line 404
    [24-Sep-2013 11:20:48 UTC] PHP Warning:  next() expects parameter 1 to be array, null given in /home/username/public_html/wp-includes/plugin.php on line 408

    NGG 2.0.22, so not strictly related to 2.0.27

    lorenzoali

    @lorenzoali

    I deactivated the plugin and then reactivated about 4 hours ago. So far it seems to be working. I’ll see what happens overnight.

    Plugin Author photocrati

    @photocrati

    @john – We would greatly appreciate a Bug report specifically for your issue (we believe the other issues are already being addressed). Please also specify the error message “PHP Warning: next() expects parameter 1 to be array” as well as our request for this report.

    It would be very important for our developers to be able to get those log in credentials and FTP credentials for your WordPress installation as well.

    Thanks!

    – Cais.

    john

    @johnpaulbeaver

    I have submitted the bug report as per your request via http://www.nextgen-gallery.com/report-bug/

    No offense, but I’m not going to be providing your developers with log in credentials to our live production site.

    This error is being experienced by many installations other than our own.

    Plugin Author photocrati

    @photocrati

    @john – Thanks for the Bug Report, but the error messages you reported originally are not noted anywhere else and we are unable to recreate them in our test environments; and, I completely understand your choice not to share log in credentials for your production site.

    Are you seeing the same issues/errors on your test/development sites? A set of credentials for one of those would be just as valuable to our developers for troubleshooting this issue. Please feel free to respond to our Bug Report conversation with those details.

    Thanks!

    – Cais.

    Plugin Author photocrati

    @photocrati

    Hey all,

    Erick here. Just following up on this. We’re actively prepping a NG release right now and this issue is one I think we definitely need to see included. There are actually several issues reported above, and we’ve tracked down and resolved all but this one:

    PHP Warning: next() expects parameter 1 to be array, integer given in /wordpress/htdocs/wp-includes/plugin.php on line 408

    Right now, we can’t duplicate it or reproduce it ourselves under any conditions. And we don’t have login credentials for any site with the issue.

    Cais had asked @john for login credentials. But I several others above were reporting the same error. If any of you are willing to provide login credentials, then we’ll work on this immediately and try to push out an update immediately.

    Just submit a report here: http://www.nextgen-gallery.com/report-bug/, reference this thread, and include Erick in the title so I’ll see it and forward it straight to our developers.

    If we can’t get a set of credentials for this, we just can’t resolve it. In that case, we’ll probably push out the next update without a fix for this and just wait until we do get some credentials at some point.

    Thanks in advance for any assistance. And sincere apologies for the difficulties.

    Kerwood

    @kerwood

    @defjam – Oops, forgot to tell which file 🙂 .. Its some where around line 404 in the wp-includes/plugin.php file.

    Original line.
    while ( next($wp_filter[$tag]) !== false );

    Modified
    while ( is_array($wp_filter[$tag]) && next($wp_filter[$tag]) !== false );

Viewing 15 replies - 1 through 15 (of 56 total)
  • The topic ‘[Resolved] New Bug Filling Up Log Files Taking Down Site – 20gig And Counting’ is closed to new replies.