Support » Fixing WordPress » New Blog Posts End Up As Archives

  • Resolved lightshadowlabs


    I’m fairly new to the inner workings of WordPress. What I’m trying to understand is why new blog posts are 1) posting to an archive subdirectory 2) why deleting the pages that were containing the blogs are still remaining. I did not build this site and I am trying to understand how to make things act normal and predictable. I only need one page for blog posts and that should be “Blog”. For some reason, there is a “Journal” page and another “blog” page. These were deleted or so I thought. Thank you for any insight to this noob question.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Go to your admin Settings > Permalinks page and see what it says there.

    From your Blog page (which is the second one — you can tell because the slug is blog-2), you can see that each post has a permalink that looks like archives/xxx, which is probably the post ID. It’s not that WordPress is “posting to an archive subdirectory”, but that is the permalink structure that was chosen for your site.
    It’s also not “deleting the pages that were containing the blogs”. The Journal page is just a post with the title “Journal”. I don’t know where your other “blog” page is, but it must be renamed or something because WordPress is redirecting the blog slug to blog-2.

    @joyously Thank you for the information. That is clearing things up. I have changed Settings>Permalinks to Post name instead of Numeric (which it was). Now I am considering using the Optional Category base so the permalink makes more sense.

    I do have a Blog and Journal page in the trash currently. I’m going to empty the trash to see if that helps to rename blog-2 to just blog to clean things up a bit more…okay, just did that and corrected the permalink on blog. Now I do see what you mean that the title on the post is Journal. That’s an easy fix.

    Thank you again!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.