WordPress.org

Support

Support » Plugins and Hacks » new auto update for plugins not working

new auto update for plugins not working

  • Auto update for Akismet 2.02 pulls this error message: Fatal error: Cannot redeclare class pclzip in /home/savoring/public_html/wordpress/wp-admin/includes/class-pclzip.php on line 162

    Is this something I can fix?

Viewing 15 replies - 16 through 30 (of 42 total)
  • The permissions need to be set properly for the auto update to be able to modify the plugin files. Make sure that the files and directories aren’t read only or something.

    Hi Otto42, checked and double checked; permissions are set fine but the errors still persist. Any other ideas?

    Come now guys, this is quite important as I’m not the only one having this problem. Just got off AIM and 2 of my friends are also experiencing this in 2.5

    It seems to be a problem in 2.5 so it needs a fix…where are the freakin Guru’s at?

    Yeah, this is not working for me, either. I’ve changed the permissions to 777 on the plug-ins directory, the individual directory for the plug-in I was trying to upgrade, and it did not work. Help!

    I changed the permissions back to 755, since this did not resolve the issue.

    If you can ssh in to your server… A recursive chmod’ing of the plugins folder worked for me. I don’t know why it didn’t work when I chmod’d the plugins folder and the folder I was trying to upgrade, but I suspect it was because every single file in the folder needed the permissions changed in order for the upgrade to go through.

    Now the automatic plugin upgrade feature works for me.

    Try this, with the full path to your plugins directory at the end from the command line in an ssh session:

    chmod -R 777 /the/path/to/your/plugins/directory

    Add Sticky to the list of plugin problems. When its activated with 2.5 all the post disappear and a message is in the main area that says “what you’re looking for isn’t here” or some such thing. Its causing the same problem on all updates (7 test sites and three live blogs). I’ve run through every possibility I can think of… even committing the Einstein sin of doing the same thing over and over: Permalinks, new copy of Sticky, configuring Sticky in all possible ways, etc. Nothing works.

    Also, if you are paranoid about permissions like I am… you need to do another recursive chmod’ing back to 755 or whatever you’d like when you’re done. Kind of takes the fun out of an “automatic plugin upgrade” but it is easier than downloading, unpacking, and reuploading.

    Hi Cartermason, I tried your fix above and didn’t work for me. Still getting the exact same error. Thanks for the reply though.

    Anyone else have any clues?

    I was getting the same error, so I changed the permission for the directory of the plugin i was trying to update to 777 and it worked…

    Also, if you are paranoid about permissions like I am… you need to do another recursive chmod’ing back to 755 or whatever you’d like when you’re done. Kind of takes the fun out of an “automatic plugin upgrade” but it is easier than downloading, unpacking, and reuploading.

    WordPress normally does a “direct” method to access files when doing the upgrade, but it does have alternate methods.

    The main other method is FTP. It will make an FTP connection back to itself and put the files in that way. This bypasses permission problems if you’d like to use it in this way.

    Normally, it only uses this when it detects that files it creates have the wrong owner name, but you can modify the code to force it. Edit the wp-admin/includes/file.php file. At the end of the file, you’ll find this function:

    function get_filesystem_method() {
    ...

    Modify it to this:

    function get_filesystem_method() {
    /*	$tempFile = tempnam(get_temp_dir(), 'WPU');
    
    	if ( getmyuid() == fileowner($tempFile) ) {
    		unlink($tempFile);
    		return 'direct';
    	} else {
    		unlink($tempFile);
    	}
    */
    	if ( extension_loaded('ftp') ) return 'ftpext';
    	if ( extension_loaded('sockets') || function_exists('fsockopen') ) return 'ftpsockets'; //Sockets: Socket extension; PHP Mode: FSockopen / fwrite / fread
    	return false;
    }

    All I did was to remove the “direct” check. Now it’ll be forced to use FTP, if that is available to it.

    Finally! Thanks a lot Mr. Otto42!

    Error: There was an error connecting to the server, Please verify the settings are correct.

    I’m getting this error!! can some one help?

    Mine was working but now I am recieving the same error as mayooresan whenever I attempt to preform FTP updates.

    ow do you disable or reset the preferences from the auto update? Id like to see if I get errors if I do not try to update via FTP just to try to isolate points of failure.

    Make sure you have not uploaded any other directories within your plugin directory.

    I realised that windows had added a : _vti_cnf subdirectory to some of my plugin directories and so the auto upgrade could not remove the old plugin and update

    @marcoart
    some plugins have their own folders inside plugin directory!!! 🙁

Viewing 15 replies - 16 through 30 (of 42 total)
  • The topic ‘new auto update for plugins not working’ is closed to new replies.
Skip to toolbar