Support » Plugin: Five Star Business Profile and Schema » Version: 1.2.8 – Fatal PHP errors

  • Version: 1.2.8 broke my sites until I disabled the plugin. Sample PHP errors:

    Warning: require_once(…/wp-content/plugins/business-profile/includes/class-schemas-manager.php): failed to open stream: No such file or directory in /home/…/wp-content/plugins/business-profile/business-profile.php on line 116

    Fatal error: require_once(): Failed opening required ‘/home/…/wp-content/plugins/business-profile/includes/class-schemas-manager.php’ (include_path=’.:/opt/alt/php73/usr/share/pear’) in /home/…/wp-content/plugins/business-profile/business-profile.php on line 116

    • This topic was modified 9 months, 2 weeks ago by fisnollo.
Viewing 10 replies - 1 through 10 (of 10 total)
  • I have had the same issue. I disable the plugin and site came back up.
    Any fix?

    Cheers,

    Same problem; I rolled back the update.

    Same issue. Following this thread.

    Broke multiple sites too…

    
    Warning: require_once(/home/303725.cloudwaysapps.com/ddegrxetwv/public_html/wp-content/plugins/business-profile/includes/class-schemas-manager.php): failed to open stream: No such file or directory in /home/303725.cloudwaysapps.com/deegrxetwv/public_html/wp-content/plugins/business-profile/business-profile.php on line 116
    
    Fatal error: require_once(): Failed opening required '/home/303725.cloudwaysapps.com/deegrxetwv/public_html/wp-content/plugins/business-profile/includes/class-schemas-manager.php' (include_path='.:/usr/share/php') in /home/303725.cloudwaysapps.com/deegrxetwv/public_html/wp-content/plugins/business-profile/business-profile.php on line 116
    There has been a critical error on your website. Please check your site admin email inbox for instructions.
    
    Learn more about debugging in WordPress.
    

    Same here. Received critical error when visiting my site or admin and had to use the new recovery link provided by WordPress.

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 116 of the file /home/SERVER.cloudwaysapps.com/MYAPP/public_html/wp-content/plugins/business-profile/business-profile.php. Error message: require_once(): Failed opening required ‘/home/SERVER.cloudwaysapps.com/MYAPP/public_html/wp-content/plugins/business-profile/includes/class-schemas-manager.php’ (include_path=’.:/usr/share/php’)

    Really hope this gets fixed! I’d love to reactivate the plugin in the near future.

    same for me , need a fix ASAP

    Same problem here. I downloaded the previous version of the file business-profile.php and replaced it. so far, everything seems to work with this hotfix.
    https://plugins.trac.wordpress.org/browser/business-profile/tags/1.2.7/business-profile.php

    Also, if you change the version on line 6 to 1.2.8, WP won’t bug you into updating to the broken version.

    Same issue on a few sites which update automatically. Hotfix works fine though until they fix it. Thanks

    Plugin Support jaysupport

    (@jaysupport)

    Hi,

    We’ve just released an update to correct the require that was causing the error in version 1.2.8. Please update to version 1.2.9.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Version: 1.2.8 – Fatal PHP errors’ is closed to new replies.