Support » Installing WordPress » New 2.5.1 install – Blank Dashboard

  • I just did a totally clean fresh install of WP 2.5.1 – default themes, no added plug-ins, all totally virgin ..

    This install part went fine .. everything verified .. but logging into the Dashboard, all I get is a blank page ..

    The actual blog shows up just fine .. but the admin area .. blanksville.

    I searched the forum and saw where some had similar issues when upgrading – mostly due to third party plug-ins .. but that’s not the case here .. this was a straight up fresh install .. just what was in the 2.5.1 package.

    Any help here?


Viewing 15 replies - 1 through 15 (of 19 total)
  • some more details ..

    the blog shows up fine ..

    the wp-login.php page shows up fine

    Dashboard .. for that matter EVERYTHING within the wp-admin directory .. bounces up a blank page ..

    As a test, I entered a false page URL within the wp-admin directory “wp-admin/XXXaaa.php” .. I correctly get a 404 error ..

    So .. the page URL *is* recognized as a valid address, but all I’m getting are blank pages within the wp-admin directory.

    Does that help anyone to help me squish this bug?

    Thanks again.

    Same thing happens to me too. I restored my backup and redid the upgrade process. And same thing .. now Three times in a row. can see the public side of wordpress, but the wp-admin side is blank. not 404 errors… just blank!

    hey on try #2, i didn’t just deactive plugins, I completely removed them first. wordpress ran find without my plugins. then did the upgrade. still get a blank admin area. maybe that will help.

    Thanks .. but again .. mine is a fresh install (totally virgin – just the ‘official’ package) .. no third-party plug-ins .. but I did think to try removing the default hello and akismet plug-ins .. just to see if it’s an overall plug-in issue .. still didn’t work ..

    Thanks though ..

    Can you give us a link?

    If you can see the site, but not the admin, some files are missing, i think. Perhaps you can compare your list of files online with what you uploaded?

    I thought of that .. checked … everything is there .. file for file ..

    Unfortunately, I can’t give a link yet .. client/privacy etc etc ..

    Thanks though ..

    Think I’ll sleep on it ..

    More checking .. seems this is NOT a 2.5.x issue .. tried downgrading to 2.3.3 and even 2.2.3 .. and still the same issue .. everything works .. EXCEPT all I get is blanks in the Dashboard (and the wp-admin area overall)

    Anyone have any idea of what can be going on?


    At this point, I’m pretty sure this is a server-side issue, and not a WP/install issue. As a control, I did the same upload on a different server system .. and 2.5.1 took to it like a champ ..

    So .. now we just have to go digging through the server ..

    I already know it meets the MySQL and PHP version requirements, so that’s knocked off the list. I also ran into a note about making sure enough memory is allocated to the php.ini file .. that’s good too .. so I guess it’s needle-in-a-haystack time. If I ever find out I’ll post it here in case some other poor schmoe runs into this problem.

    Of course, if there’s a poor schmoe out there who’s been through this .. please reply.


    Found this on another thread. Worked for me.

    I have the same problem. It works fine on my local machine, but fails on the remote server. I tried disabling wp_dashboard_setup() call in wp-admin/index.php, it works. It’s a good workaround, but limits the dashboard view.
    Have you tried increasing memory_limit in php.ini? I read it should do it, but could not try it on the server.

    I just upgraded to 2.5.1. I’ve been running WP for several years and upgrades are usually a snap, but I’ve got this same problem. Everything is fine, but the wp-admin/index page is blank. Because I know the URLs for some admin areas I was able to access them by typing it in—everything works except: wp-admin/index.php and wp-admin/import.php

    I deactivated my plugins before the upgrade. I did everything I was supposed to. I tried reuploading the files from a fresh download of the zip file and for one brief moment I got the Dashboard page, then I click around the dash a bit and it disappeared. 🙁 I have redone the upgrade several times now and I’m still not getting the admin/index page. 🙁

    I have tried the upgrade with the default theme, with the old config file, with no plugins in the directory, I’ve tried resetting the permissions, I’ve deleting, reuploaded and upgraded more times than I can count. I’m NOT going to hack the code as suggested above. I want an official fix and an explanation of what’s going on so I can avoid this mess in the future.


    I have completed a clean install of WP 2.5.1 along with default themes etc; When I go to my dashboard “Write”,”Settings”,”Design”, etc are missing? When I enter “Admin.php” I receive the following (2) messages = Warning: main(ABSPATHwp-admin/includes/bookmark.php) [function.main]: failed to open stream: No such file or directory in /home/xxxxxxxx/public_html/Infomission/Blog/wp-admin/includes/admin.php on line 3 and Fatal error: main() [function.require]: Failed opening required ‘ABSPATHwp-admin/includes/bookmark.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/xxxxxxxx/public_html/Infomission/Blog/wp-admin/includes/admin.php on line 3

    I have checked my server also many scripts.text and no results. I have read eveything I thought apprioate in regard to finding a result! I am just tearing my hair out now. The “Blog” appears however in default theme in IE,Firefox,Opera,Flock etc; this is what started this I wish to change the theme!


    Dashboard is still blank after the upgrade. At least most of the time. It showed up spontaneously once last night and disappeared as soon as I clicked away. Counting the other time it popped up—and all the attempts I’ve made I’d say I can access wp-admin/index.php about 2% of the time. 🙁 I repeat what I posted before: if I type in the URL for other areas of the dashboard I can navigate to them, except wp-admin/index and import.php. This smells like a bug to me. Is wordpress working on a fix?

    Well after many days somehow, I finally got the dashboard as we know it. Now, I would like to add some plugins ! Reading through all the writings, they refer to index.php as your main page. However! When I go my server and enter the folder I find (2-3) index.php files within the folder. For example under wp-admin.php there appears an index.php etc; Referring to the first index.php folder it contains only the following = <?php/* Short and sweet */define(‘WP_USE_THEMES’, true);require(‘./wp-blog-header.php’);?> whereas wp-admin.php which also has a index.php contains the following which is entirely different ! = <?phprequire_once(‘admin.php’);require_once(ABSPATH . ‘wp-admin/includes/dashboard.php’);wp_dashboard_setup();function index_js() {?><script type=”text/javascript”>jQuery(function($) { var ajaxWidgets = { dashboard_incoming_links: ‘incominglinks’, dashboard_primary: ‘devnews’, dashboard_secondary: ‘planetnews’, dashboard_plugins: ‘plugins’ }; $.each( ajaxWidgets, function(i,a) { var e = jQuery(‘#’ + i + ‘ div.dashboard-widget-content’).not(‘.dashboard-widget-control’).find(‘.widget-loading’); if ( e.size() ) { e.parent().load(‘index-extra.php?jax=’ + a); } } );});</script><?php}add_action( ‘admin_head’, ‘index_js’ );function index_css() { wp_admin_css( ‘css/dashboard’ );}add_action( ‘admin_head’, ‘index_css’ );wp_enqueue_script( ‘jquery’ );$title = __(‘Dashboard’);$parent_file = ‘index.php’;require_once(‘admin-header.php’);$today = current_time(‘mysql’, 1);?><div class=”wrap”><h2><?php _e(‘Dashboard’); ?></h2><div id=”rightnow”><h3 class=”reallynow”> <span><?php _e(‘Right Now’); ?></span><?php if ( $can_edit_posts = current_user_can( ‘edit_posts’ ) ) : ?> <?php _e(‘Write a New Post’); ?><?php endif; if ( $can_edit_pages = current_user_can( ‘edit_pages’ ) ) : ?> <?php _e(‘Write a New Page’); ?><?php endif; ?> <br class=”clear” /></h3><?php$num_posts = wp_count_posts( ‘post’ );$num_pages = wp_count_posts( ‘page’ );$num_cats = wp_count_terms(‘category’);$num_tags = wp_count_terms(‘post_tag’);$post_type_texts = array();if ( !empty($num_posts->publish) ) { // with feeds, anyone can tell how many posts there are. Just unlink if !current_user_can $post_text = sprintf( __ngettext( ‘%s post’, ‘%s posts’, $num_posts->publish ), number_format_i18n( $num_posts->publish ) ); $post_type_texts[] = $can_edit_posts ? “$post_text” : $post_text;}if ( $can_edit_pages && !empty($num_pages->publish) ) { // how many pages is not exposed in feeds. Don’t show if !current_user_can $post_type_texts[] = ‘‘.sprintf( __ngettext( ‘%s page’, ‘%s pages’, $num_pages->publish ), number_format_i18n( $num_pages->publish ) ).’‘;}if ( $can_edit_posts && !empty($num_posts->draft) ) { $post_type_texts[] = ‘‘.sprintf( __ngettext( ‘%s draft’, ‘%s drafts’, $num_posts->draft ), number_format_i18n( $num_posts->draft ) ).’‘;}if ( $can_edit_posts && !empty($num_posts->future) ) { $post_type_texts[] = ‘‘.sprintf( __ngettext( ‘%s scheduled post’, ‘%s scheduled posts’, $num_posts->future ), number_format_i18n( $num_posts->future ) ).’‘;}if ( current_user_can(‘publish_posts’) && !empty($num_posts->pending) ) { $pending_text = sprintf( __ngettext( ‘There is %2$s post pending your review.’, ‘There are %2$s posts pending your review.’, $num_posts->pending ), ‘edit.php?post_status=pending’, number_format_i18n( $num_posts->pending ) );} else { $pending_text = ”;}$cats_text = sprintf( __ngettext( ‘%s category’, ‘%s categories’, $num_cats ), number_format_i18n( $num_cats ) );$tags_text = sprintf( __ngettext( ‘%s tag’, ‘%s tags’, $num_tags ), number_format_i18n( $num_tags ) );if ( current_user_can( ‘manage_categories’ ) ) { $cats_text = “$cats_text“; $tags_text = “$tags_text“;}$post_type_text = implode(‘, ‘, $post_type_texts);// There is always a category$sentence = sprintf( __( ‘You have %1$s, contained within %2$s and %3$s. %4$s’ ), $post_type_text, $cats_text, $tags_text, $pending_text );$sentence = apply_filters( ‘dashboard_count_sentence’, $sentence, $post_type_text, $cats_text, $tags_text, $pending_text );?><p class=”youhave”><?php echo $sentence; ?></p><?php$ct = current_theme_info();$sidebars_widgets = wp_get_sidebars_widgets();$num_widgets = array_reduce( $sidebars_widgets, create_function( ‘$prev, $curr’, ‘return $prev+count($curr);’ ) );$widgets_text = sprintf( __ngettext( ‘%d widget’, ‘%d widgets’, $num_widgets ), $num_widgets );if ( $can_switch_themes = current_user_can( ‘switch_themes’ ) ) $widgets_text = “$widgets_text“;?><p class=”youare”> <?php printf( __( ‘You are using %1$s theme with %2$s.’ ), $ct->title, $widgets_text ); ?> <?php if ( $can_switch_themes ) : ?> <?php _e(‘Change Theme’); ?> <?php endif; ?> <?php update_right_now_message(); ?></p><?php do_action( ‘rightnow_end’ ); ?><?php do_action( ‘activity_box_end’ ); ?></div><!– rightnow –><br class=”clear” /><div id=”dashboard-widgets-wrap”><?php wp_dashboard(); ?></div><!– dashboard-widgets-wrap –></div><!– wrap –><?php require(‘./admin-footer.php’); ?>

    I simply donot wish to mess this up ! Which index.php do I change the source code on? Sorry for the long jargon / read and thank you.

    Same problem. I even tried to fix the admin.php per:
    The fact is the admin/pwd (wp-login.php) just cycles to a blank (wp-login.php). It does not cycle to (wp-admin/admin.php) or (wp-admin/index.php). Anyone with some more ideas?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘New 2.5.1 install – Blank Dashboard’ is closed to new replies.