Support » Plugin: Jetpack by » Network sites unavailable after upgrade to 2.3.1

  • I run a multisite with the secondary blogs pointing to subdomains. After updating my network sites became unavailable with a 404 error. I thought it was related to some host issues at Hostgator first. Tech support couldn’t fix it, they recommended installing a backup of my entire site, which I did, static files only. Database was left intact. That did not fix the issue.

    After fiddling with some settings in Cpanel, I got it to work again. I had to get rid of all my subdomains and add them again, make sure they pointed to the root where WordPress was installed.

    Everything was working fine, but the site restore took me back to just before the Jetpack upgrade. As soon as I upgraded Jetpack, the network sites became unavailable again! I tried deactivating the plugin, but that still didn’t help. Fortunately, removing my subdomains and adding them again did the trick.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    Could you try to delete the existing Jetpack plugin files, and then reinstall the plugin manually?

    If you still experience issues, could you check your error logs in order to find out more about the errors returned by your site? If you do not have access to these logs, your hosting provider should be able to help.


    I don’t think you read my entire post. I got everything working again.


    Upgrading Jetpack broke subdomains on multisite network

    Restored to earlier version of entire web site, including Jetpack. Still broken.

    Re-added subdomains in hosting panel – Subdomains Fixed.

    Upgraded Jetpack again – Subdomains broke.

    Deleted and then added subdomains in host panel – everything fixed.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    My bad, I did miss your last sentence in the first post.
    I’m afraid I’m not too familiar with the way Hostgator’s domain management panel works, and why such changes would affect code hosted on your site.

    It could be useful to check your network’s error logs to find out more about the error that caused the 404 on your sites. Could you have a look, and paste the results here?


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Network sites unavailable after upgrade to 2.3.1’ is closed to new replies.